summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-04-12 19:48:20 +0200
committerJohannes Huber <johu@gentoo.org>2018-04-12 19:48:20 +0200
commit0e7d36c32d9907b9f21d2423b1f348c90368cfb5 (patch)
tree9331f8920d73f7005db04ad7907c473d2f872fcc /app-office/libalkimia
parentdev-ruby/bindata: add ruby25 (diff)
downloadgentoo-0e7d36c32d9907b9f21d2423b1f348c90368cfb5.tar.gz
gentoo-0e7d36c32d9907b9f21d2423b1f348c90368cfb5.tar.bz2
gentoo-0e7d36c32d9907b9f21d2423b1f348c90368cfb5.zip
app-office/libalkimia: Version bump 7.0.2
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'app-office/libalkimia')
-rw-r--r--app-office/libalkimia/Manifest1
-rw-r--r--app-office/libalkimia/libalkimia-7.0.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-office/libalkimia/Manifest b/app-office/libalkimia/Manifest
index f49dd9d583f7..cc69ff115bf4 100644
--- a/app-office/libalkimia/Manifest
+++ b/app-office/libalkimia/Manifest
@@ -1 +1,2 @@
DIST alkimia-7.0.1.tar.xz 38400 BLAKE2B c6dccf0702ae42bfcebfa20fc34233766ab4b08c81d7b8aa8af2be2003560f2e088e922a0ec5656c6f8e34d3f3a8348fb6315c3e5aecf72cda9fa2506e1a2161 SHA512 7f72eaf69ad38c5478498a212f6f644ab76a27aec588ff8817414c7e36190568012cd2faff7ae31978beec670539ac93e55f3637a331e90738bddc11a423138c
+DIST alkimia-7.0.2.tar.xz 38420 BLAKE2B ea2cc8dd80e2b9b2501d26936aa7d2799d040e8cf86f9adb4785e676046f3c76d0cbe3267e4159582086d910be35020bbc634140d32cc7e5588d06cf75a115a3 SHA512 275ea48cd33caed9393a170efcc6053a581c1cc000862dd73a63bdb6de3e3c3ad2e492901a859e517033e1239e297a43088580553efe32f1d99a85051f5af3e4
diff --git a/app-office/libalkimia/libalkimia-7.0.2.ebuild b/app-office/libalkimia/libalkimia-7.0.2.ebuild
new file mode 100644
index 000000000000..6ddc34c445af
--- /dev/null
+++ b/app-office/libalkimia/libalkimia-7.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+KMNAME="alkimia"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KMNAME}/${PV}/${KMNAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library with common classes and functionality used by KDE finance applications"
+HOMEPAGE="https://www.linux-apps.com/content/show.php/libalkimia?content=137323"
+LICENSE="LGPL-2.1"
+SLOT="0/7"
+IUSE="doc"
+
+RDEPEND="
+ $(add_qt_dep qtdbus)
+ dev-libs/gmp:0=[cxx]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package doc Doxygen)
+ )
+ kde5_src_configure
+}