summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-08-31 21:57:22 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-09-17 23:32:12 +0200
commit34bdd64bb7c039a459f0442af74eb128e5600498 (patch)
tree67419e6e12197e8bd2e08ed601b56b79c5be6872 /app-office/libreoffice
parentapp-office/libreoffice: Drop mergelibs hack (diff)
downloadgentoo-34bdd64bb7c039a459f0442af74eb128e5600498.tar.gz
gentoo-34bdd64bb7c039a459f0442af74eb128e5600498.tar.bz2
gentoo-34bdd64bb7c039a459f0442af74eb128e5600498.zip
app-office/libreoffice: Really exclude clang from GCC version check
Gentoo-bug: 589948 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/libreoffice-5.1.4.2.ebuild4
-rw-r--r--app-office/libreoffice/libreoffice-5.2.9999.ebuild4
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild4
3 files changed, 3 insertions, 9 deletions
diff --git a/app-office/libreoffice/libreoffice-5.1.4.2.ebuild b/app-office/libreoffice/libreoffice-5.1.4.2.ebuild
index 49088e732694..e8cee345501c 100644
--- a/app-office/libreoffice/libreoffice-5.1.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-5.1.4.2.ebuild
@@ -265,9 +265,7 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
check-reqs_pkg_pretend
- if [[ $(tc-getCC) == clang ]] ; then
- : # ignore clang, which works
- elif [[ $(gcc-major-version) -lt 4 ]] || {
+ if ! $(tc-is-clang) && [[ $(gcc-major-version) -lt 4 ]] || {
[[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]]; } then
eerror "Compilation with gcc older than 4.7 is not supported"
die "Too old gcc found."
diff --git a/app-office/libreoffice/libreoffice-5.2.9999.ebuild b/app-office/libreoffice/libreoffice-5.2.9999.ebuild
index 68e7b73e08b1..d2494129c60b 100644
--- a/app-office/libreoffice/libreoffice-5.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.2.9999.ebuild
@@ -259,9 +259,7 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
check-reqs_pkg_pretend
- if [[ $(tc-getCC) == clang ]] ; then
- : # ignore clang, which works
- elif [[ $(gcc-major-version) -lt 4 ]] || {
+ if ! $(tc-is-clang) && [[ $(gcc-major-version) -lt 4 ]] || {
[[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]]; } then
eerror "Compilation with gcc older than 4.7 is not supported"
die "Too old gcc found."
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index b95de748e3ed..7dff9ae439b1 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -259,9 +259,7 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
check-reqs_pkg_pretend
- if [[ $(tc-getCC) == clang ]] ; then
- : # ignore clang, which works
- elif [[ $(gcc-major-version) -lt 4 ]] || {
+ if ! $(tc-is-clang) && [[ $(gcc-major-version) -lt 4 ]] || {
[[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]]; } then
eerror "Compilation with gcc older than 4.7 is not supported"
die "Too old gcc found."