summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-17 19:43:57 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-17 19:43:57 +0100
commitde75fdb7179f8afadb90b8edc2519b49cff7aad7 (patch)
tree1548e0eca863850cd8da3b74a7d8c22038fae05d /app-office/pinpoint
parentmedia-gfx/meshlab: patches for plugins added bug #558758. By Dominik Joe Pant... (diff)
downloadgentoo-de75fdb7179f8afadb90b8edc2519b49cff7aad7.tar.gz
gentoo-de75fdb7179f8afadb90b8edc2519b49cff7aad7.tar.bz2
gentoo-de75fdb7179f8afadb90b8edc2519b49cff7aad7.zip
app-office/pinpoint: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-office/pinpoint')
-rw-r--r--app-office/pinpoint/Manifest1
-rw-r--r--app-office/pinpoint/pinpoint-0.1.8.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-office/pinpoint/Manifest b/app-office/pinpoint/Manifest
index bcd986fd67b5..ce506f096d98 100644
--- a/app-office/pinpoint/Manifest
+++ b/app-office/pinpoint/Manifest
@@ -1,2 +1,3 @@
DIST pinpoint-0.1.6.tar.xz 773492 SHA256 812a6e49ccd8bcd6cd0927fda98ceb0f2bafb1f18246bd2d75ea96c3c971f34b SHA512 5db48b64eb69fe677b5a4c226e989ce6eaea483396de82fdd644e4c4ed238ad5fd11f956ed6ffd1badbdfa8c9d24e9ec23375572360094721135c3b6a8347c27 WHIRLPOOL de1749d53b1512e0af761ef7457f01975b90a3301bed1b9e53a267349358b849be1f04d9a74aef98b02a6ddbf200c1ecd7dbe466ed9a207f5a1659a311cb0e57
+DIST pinpoint-0.1.8.tar.xz 772980 SHA256 5a207dd1a35681b7268e6aa5ff9b2c5381f4cc63e5f2e5695997ca9d3264e8ca SHA512 dc41405f79bf03b6a7c77ec31304e505d4ae2d13407304fbcc2f338dfe175f91db3c554ea06ba8041edbf99a12551f16efed98b5a07f29b7f24255cad2b1b94d WHIRLPOOL 4ddda5e82faa2ce2d426adccfbb0d834161d354cf6947526a829b2126e1f9067b5632925c2b3d29a42030cd815a8295922443ddf314c76e5156539a7f051c484
DIST pinpoint-215ccad331a39c6e95d173938fcfffe6eb4d75d6.tar.xz 708020 SHA256 1303581f09ff6414269fe0642f7ce51094ebc5cee5101ef5b3113054da0bc8e9 SHA512 efbc711e034a968b104cca669fedaae8c1f088f598996843a65849f632ebdbff3df8d36225852b24327c26e2b972b1c5097775531b23ebc3eedf62415346f27e WHIRLPOOL 1c80ee81257c42b10ab860eabd4a95c61a9980b80cfb901ce167e70cf0046586b74e3670bffdb4342adfd378fb02c97ecfb1f4ae59d3e0ce09b205f9ef1e7ebd
diff --git a/app-office/pinpoint/pinpoint-0.1.8.ebuild b/app-office/pinpoint/pinpoint-0.1.8.ebuild
new file mode 100644
index 000000000000..bb1445508d12
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://wiki.gnome.org/Apps/Pinpoint"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND="
+ >=media-libs/clutter-1.23.7:1.0
+ >=media-libs/clutter-gtk-1.6:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( media-libs/clutter-gst:3.0 )
+ pdf? ( gnome-base/librsvg:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ gnome2_src_configure \
+ --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ gnome2_src_install
+
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+}