summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-09 14:32:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-09 14:46:14 +0100
commit011a496c85cf6f36b24082a3ac55f6b63162f2e5 (patch)
tree9d3c9586e516f95061edea7638773d003d49bc44 /app-office
parentnet-analyzer/wapiti: 3.0.0 bump (diff)
downloadgentoo-011a496c85cf6f36b24082a3ac55f6b63162f2e5.tar.gz
gentoo-011a496c85cf6f36b24082a3ac55f6b63162f2e5.tar.bz2
gentoo-011a496c85cf6f36b24082a3ac55f6b63162f2e5.zip
app-office/scribus: Fix build w/ x86 on 17.0 profile
Closes: https://bugs.gentoo.org/642242 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/files/scribus-1.5.3-x86-fpic.patch16
-rw-r--r--app-office/scribus/scribus-1.5.3-r1.ebuild1
-rw-r--r--app-office/scribus/scribus-9999.ebuild2
3 files changed, 18 insertions, 1 deletions
diff --git a/app-office/scribus/files/scribus-1.5.3-x86-fpic.patch b/app-office/scribus/files/scribus-1.5.3-x86-fpic.patch
new file mode 100644
index 000000000000..03d4dc4daa3c
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.5.3-x86-fpic.patch
@@ -0,0 +1,16 @@
+--- a/CMakeLists.txt 2017-05-28 11:10:27.000000000 +0200
++++ b/CMakeLists.txt 2018-01-09 14:26:14.494922353 +0100
+@@ -155,11 +155,11 @@
+ set(ARCH_HPPA 1)
+ endif()
+
+-# We need to pass -fPIC to lib2geom on amd64, mips, mipsel, and hppa. See:
++# We need to pass -fPIC to lib2geom on amd64, mips, mipsel, hppa and x86. See:
+ # http://www.gentoo.org/proj/en/base/amd64/howtos/index.xml?part=1&chap=3 and
+ # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=559133
+
+-if (ARCH_X86_64 EQUAL 1 OR ARCH_HPPA EQUAL 1 OR ARCH_MIPS EQUAL 1 OR ARCH_MIPS_64 EQUAL 1 OR ARCH_PPC_64 EQUAL 1)
++if (ARCH_X86 EQUAL 1 OR ARCH_X86_64 EQUAL 1 OR ARCH_HPPA EQUAL 1 OR ARCH_MIPS EQUAL 1 OR ARCH_MIPS_64 EQUAL 1 OR ARCH_PPC_64 EQUAL 1)
+ set(CMAKE_CXX_FLAGS_FPIC "-fPIC")
+ endif()
+
diff --git a/app-office/scribus/scribus-1.5.3-r1.ebuild b/app-office/scribus/scribus-1.5.3-r1.ebuild
index 0c8f8171b5e6..e1ed169825aa 100644
--- a/app-office/scribus/scribus-1.5.3-r1.ebuild
+++ b/app-office/scribus/scribus-1.5.3-r1.ebuild
@@ -96,6 +96,7 @@ PATCHES=(
"${FILESDIR}"/${P}-fpic.patch
"${FILESDIR}"/${P}-cmake-openssl.patch
"${FILESDIR}"/${P}-poppler-0.58.patch
+ "${FILESDIR}"/${P}-x86-fpic.patch
)
src_prepare() {
diff --git a/app-office/scribus/scribus-9999.ebuild b/app-office/scribus/scribus-9999.ebuild
index b65e60a412b2..f9c847c7aa6d 100644
--- a/app-office/scribus/scribus-9999.ebuild
+++ b/app-office/scribus/scribus-9999.ebuild
@@ -6,7 +6,6 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="tk?"
CMAKE_MAKEFILE_GENERATOR=ninja
-CMAKE_MIN_VERSION=3.2.0
inherit cmake-utils eutils flag-o-matic gnome2 python-single-r1 subversion xdg-utils
@@ -97,6 +96,7 @@ DEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}"/${P}-docdir.patch
"${FILESDIR}"/${P}-fpic.patch
+ "${FILESDIR}"/${PN}-1.5.3-x86-fpic.patch
)
src_prepare() {