summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-14 09:58:45 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-14 10:53:37 +0100
commit187c5630dcab29fca836cc08fe3d6bb82dbe51c2 (patch)
tree993a33835527a200424e21f3d3038a6767c500b0 /app-office
parentdev-python/selenium: Version Bump (diff)
downloadgentoo-187c5630dcab29fca836cc08fe3d6bb82dbe51c2.tar.gz
gentoo-187c5630dcab29fca836cc08fe3d6bb82dbe51c2.tar.bz2
gentoo-187c5630dcab29fca836cc08fe3d6bb82dbe51c2.zip
app-office/scribus: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/Manifest1
-rw-r--r--app-office/scribus/scribus-1.4.5.ebuild13
-rw-r--r--app-office/scribus/scribus-1.4.6.ebuild151
3 files changed, 159 insertions, 6 deletions
diff --git a/app-office/scribus/Manifest b/app-office/scribus/Manifest
index 517756de524b..70f48094e13e 100644
--- a/app-office/scribus/Manifest
+++ b/app-office/scribus/Manifest
@@ -1,3 +1,4 @@
DIST scribus-1.4.4.tar.xz 71274196 SHA256 a43b9d55518ccebdb770d3cdac44ebf75c60ad11c284b210f6b0bd8c7a0217ae SHA512 aafcb0870d4a3054585d79ef7d7e7726dd8bd8eb8a177bcf812a42d00583a1d684a9abb61607e69c64bf9fdb4a98258be4a5b2df5cfb7c953238bc3a6a2d34bb WHIRLPOOL dff4f44ed0600737076a233ef3c7d2fd6b534f30e9d6016b884eadab2512c3f4a8610e932207d95a597795812ec7a45128ca66b6bc294fa1336f3411595c5df9
DIST scribus-1.4.5.tar.bz2 78251228 SHA256 9f706f0561d26bb11bbe558690ae0507cd3689e381f6e17aa9411d9c4ef58498 SHA512 60db402b0fc4880f795694f3d6823ff2cedd660e7431c311ec7b75d79f09815e790da562c4cd4c080811559d1c16a3e65be8e1a348f655dbc37c3a6cec74650e WHIRLPOOL f53273810ae2b7aa35403d6e622fb0ebb67f35d454aa4667dbbe81efe5fb2de3564d346741b80c5bed33a307e8c58fe7ba695900e45f602b3a14db1cae82d948
+DIST scribus-1.4.6.tar.xz 73601104 SHA256 21e336500d9edc9c90ccf73087e5ef3df59ec3e4a3cbfec15367bcd8d078a19a SHA512 74d8a89eb767535bcd8fe5e3c55d03709d59ff8fc5280005bcc2ad36cae1d37c8442ab85abaea86fdee9f351a901c86947231001324e2d8df00cbd8e5c18d1e3 WHIRLPOOL 5c2ee366cb53720b35ffec2f7e2db244105a95ed7b14c27cf4fab7636cbdf10c6a370c0a14f65f630cd8252b22a4a3ec4b5e592c71308f78269205a89ae56fb7
DIST scribus-1.5.0.tar.xz 75867348 SHA256 a3dbe66d12719355d41ae7f2cac7a8c9d5599b12aeb5c038d939636f054e8e68 SHA512 3d3f311543019cf985e12d25d0a9bd2ea470679aee0f40d0aed4d2f1532ea3cdbd4d2e215e59b559b4301613fb71f738a348c56d09d3c6e32da0047d9e212065 WHIRLPOOL feae71d139724b4927c81cab5d13168a9e00383f9a7890484cf5ab62f001b266b4af954440bc7edc51eedb65c3ace4541a7fc0836b0f6237061d6d38371ac6ca
diff --git a/app-office/scribus/scribus-1.4.5.ebuild b/app-office/scribus/scribus-1.4.5.ebuild
index 246e7fc62f73..a123e31701c4 100644
--- a/app-office/scribus/scribus-1.4.5.ebuild
+++ b/app-office/scribus/scribus-1.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -120,13 +120,14 @@ src_install() {
if ! use scripts; then
rm "${ED}"/usr/share/scribus/scripts/*.py || die
- elif ! use tk; then
- rm "${ED}"/usr/share/scribus/scripts/{FontSample,CalendarWizard}.py || die
+ else
+ if ! use tk; then
+ rm "${ED}"/usr/share/scribus/scripts/{FontSample,CalendarWizard}.py || die
+ fi
+ python_fix_shebang "${ED}"/usr/share/scribus/scripts
+ python_optimize "${ED}"/usr/share/scribus/scripts
fi
- python_fix_shebang "${ED}"/usr/share/scribus/scripts
- python_optimize "${ED}"/usr/share/scribus/scripts
-
mv "${ED}"/usr/share/doc/${PF}/{en,html} || die
ln -sf html "${ED}"/usr/share/doc/${PF}/en || die
cat >> "${T}"/COPYING <<- EOF
diff --git a/app-office/scribus/scribus-1.4.6.ebuild b/app-office/scribus/scribus-1.4.6.ebuild
new file mode 100644
index 000000000000..a60d73f4b06f
--- /dev/null
+++ b/app-office/scribus/scribus-1.4.6.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit cmake-utils fdo-mime python-single-r1
+
+DESCRIPTION="Desktop publishing (DTP) and layout program"
+HOMEPAGE="http://www.scribus.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cairo debug examples hunspell +minimal +pdf scripts templates tk"
+
+# a=$(ls resources/translations/po/scribus.*ts | sed -e 's:\.: :g' | awk '{print $2}'); echo ${a}
+IUSE_LINGUAS=" af ar bg br ca cs_CZ cy da_DK de_1901 de_CH de el en_AU en_GB en_US eo es_ES et eu fi fr gl hu id it ja ko lt_LT nb_NO nl pl_PL pt_BR pt ru sa sk_SK sl sq sr sv th_TH tr uk zh_CN zh_TW"
+IUSE+=" ${IUSE_LINGUAS// / linguas_}"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ tk? ( scripts )"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/boost
+ dev-libs/hyphen
+ dev-libs/libxml2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ media-libs/libpng:0
+ media-libs/tiff:0
+ net-print/cups
+ sys-libs/zlib[minizip]
+ virtual/jpeg:0=
+ cairo? ( x11-libs/cairo[X,svg] )
+ !cairo? ( media-libs/libart_lgpl )
+ hunspell? ( app-text/hunspell )
+ pdf? ( app-text/podofo )
+ scripts? ( dev-python/pillow[tk?,${PYTHON_USEDEP}] )
+ tk? ( dev-python/pillow[tk?,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.0-minizip.patch
+ )
+
+src_prepare() {
+ cat > cmake/modules/FindZLIB.cmake <<- EOF
+ find_package(PkgConfig)
+ pkg_check_modules(ZLIB minizip zlib)
+ SET( ZLIB_LIBRARY \${ZLIB_LIBRARIES} )
+ SET( ZLIB_INCLUDE_DIR \${ZLIB_INCLUDE_DIRS} )
+ MARK_AS_ADVANCED( ZLIB_LIBRARY ZLIB_INCLUDE_DIR )
+ EOF
+
+ rm scribus/{ioapi,unzip}.[ch] || die
+
+ sed \
+ -e 's:\(${CMAKE_INSTALL_PREFIX}\):./\1:g' \
+ -i resources/templates/CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local lang langs
+ for lang in ${IUSE_LINGUAS}; do
+ if use linguas_${lang}; then
+ langs+=",${lang}"
+ else
+ sed -e "/${lang}/d" -i scribus/doc/CMakeLists.txt || die
+ fi
+ done
+
+ local mycmakeargs=(
+ -DHAVE_PYTHON=ON
+ -DPYTHON_INCLUDE_PATH="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ -DWANT_NORPATH=ON
+ -DWANT_QT3SUPPORT=OFF
+ -IUSE_LINGUAS=ON
+ -DWANT_GUI_LANG=${langs#,}
+ -DCMAKE_INSTALL_DATAROOTDIR="${EPREFIX}/usr/share"
+ -DTAG_VERSION=-${PVR}
+ $(cmake-utils_use_with pdf PODOFO)
+ $(cmake-utils_use_want cairo)
+ $(cmake-utils_use_want !cairo QTARTHUR)
+ $(cmake-utils_use_want debug DEBUG)
+ $(cmake-utils_use_want minimal NOHEADERINSTALL)
+ $(cmake-utils_use_want hunspell HUNSPELL)
+ $(cmake-utils_use_want !examples NOEXAMPLES)
+ $(cmake-utils_use_want !templates NOTEMPLATES)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ local lang file
+ for lang in ${IUSE_LINGUAS}; do
+ file="${ED}"/usr/share/scribus/translations/scribus.${lang}.qm
+ if ! use linguas_${lang} && [[ -f "${file}" ]]; then
+ rm "${file}" || die
+ fi
+ done
+
+ if ! use scripts; then
+ rm "${ED}"/usr/share/${PF}/scripts/*.py || die
+ else
+ if ! use tk; then
+ rm "${ED}"/usr/share/${PF}/scripts/{FontSample,CalendarWizard}.py* || die
+ fi
+ python_fix_shebang "${ED}"/usr/share/${PF}/scripts
+ python_optimize "${ED}"/usr/share/${PF}/scripts
+ fi
+
+ mv "${ED}"/usr/share/doc/${PF}/{en,html} || die
+ ln -sf html "${ED}"/usr/share/doc/${PF}/en || die
+ cat >> "${T}"/COPYING <<- EOF
+ ${PN} is licensed under the "${LICENSE}".
+ Please visit https://www.gnu.org/licenses/gpl-2.0.html for the complete license text.
+ EOF
+ dodoc "${T}"/COPYING
+ docompress -x /usr/share/doc/${PF}/en /usr/share/doc/${PF}/{AUTHORS,TRANSLATION,LINKS,COPYING}
+ doicon resources/icons/scribus.png
+ domenu scribus.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}