summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-07 13:12:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-07 14:49:47 +0100
commit40fd326c118a7eb8ed87a62559dfa9b1266aba97 (patch)
tree350c386c97c56820b983cba4d4225390a81beab4 /app-office
parentapp-office/calligra: Fix build with >=poppler-22.01 (diff)
downloadgentoo-40fd326c118a7eb8ed87a62559dfa9b1266aba97.tar.gz
gentoo-40fd326c118a7eb8ed87a62559dfa9b1266aba97.tar.bz2
gentoo-40fd326c118a7eb8ed87a62559dfa9b1266aba97.zip
app-office/scribus: Set WANT_CPP17 to fix build with >=poppler-22.01
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/scribus-1.5.7.ebuild11
-rw-r--r--app-office/scribus/scribus-9999.ebuild11
2 files changed, 12 insertions, 10 deletions
diff --git a/app-office/scribus/scribus-1.5.7.ebuild b/app-office/scribus/scribus-1.5.7.ebuild
index 6a826be1e707..5f63eeb1aa19 100644
--- a/app-office/scribus/scribus-1.5.7.ebuild
+++ b/app-office/scribus/scribus-1.5.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,10 +21,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
# osg
# couple of third_party libs bundled
-BDEPEND="
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
DEPEND="${PYTHON_DEPS}
app-text/libmspub
app-text/libqxp
@@ -69,6 +65,10 @@ DEPEND="${PYTHON_DEPS}
RDEPEND="${DEPEND}
app-text/ghostscript-gpl
"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
PATCHES=(
# non(?)-upstreamable
@@ -111,6 +111,7 @@ src_configure() {
local mycmakeargs=(
-DHAVE_PYTHON=ON
-DWANT_DISTROBUILD=ON
+ -DWANT_CPP17=ON
-DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/
-DPython3_EXECUTABLE="${PYTHON}"
-DWITH_BOOST=$(usex boost)
diff --git a/app-office/scribus/scribus-9999.ebuild b/app-office/scribus/scribus-9999.ebuild
index a926bffff40a..b8abdb6f421f 100644
--- a/app-office/scribus/scribus-9999.ebuild
+++ b/app-office/scribus/scribus-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,10 +23,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
# osg
# couple of third_party libs bundled
-BDEPEND="
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
DEPEND="${PYTHON_DEPS}
app-text/libmspub
app-text/libqxp
@@ -71,6 +67,10 @@ DEPEND="${PYTHON_DEPS}
RDEPEND="${DEPEND}
app-text/ghostscript-gpl
"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
PATCHES=(
# non(?)-upstreamable
@@ -109,6 +109,7 @@ src_configure() {
local mycmakeargs=(
-DHAVE_PYTHON=ON
-DWANT_DISTROBUILD=ON
+ -DWANT_CPP17=ON
-DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/
-DPython3_EXECUTABLE="${PYTHON}"
-DWITH_BOOST=$(usex boost)