summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 13:56:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 13:59:09 +0100
commit5d807dbc22e70f8bcce8fd99637b0464686d26fd (patch)
tree8fcccb23feb7ce6c02f4740d285dd19e1c66752a /app-office
parentdev-libs/liborcus: Fix build with GCC-11, python3_9 (diff)
downloadgentoo-5d807dbc22e70f8bcce8fd99637b0464686d26fd.tar.gz
gentoo-5d807dbc22e70f8bcce8fd99637b0464686d26fd.tar.bz2
gentoo-5d807dbc22e70f8bcce8fd99637b0464686d26fd.zip
app-office/libreoffice: Fix build with GCC-11
Reported-by: Geoff Leach <gl@cs.rmit.edu.au> Closes: https://bugs.gentoo.org/766656 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-7.0.4.2-gcc11.patch31
-rw-r--r--app-office/libreoffice/libreoffice-7.0.4.2.ebuild3
2 files changed, 34 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-7.0.4.2-gcc11.patch b/app-office/libreoffice/files/libreoffice-7.0.4.2-gcc11.patch
new file mode 100644
index 000000000000..748a6c21d742
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-7.0.4.2-gcc11.patch
@@ -0,0 +1,31 @@
+From 8830cf86b146b1252ac37f351a23246088d569b0 Mon Sep 17 00:00:00 2001
+From: Jeff Law <law@redhat.com>
+Date: Tue, 3 Nov 2020 08:05:03 -0700
+Subject: include cstddef for gcc11
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Change-Id: I2f845ce9bb660ad6c1eea80ea81dd71add2c0db1
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107191
+Tested-by: Jenkins
+Reviewed-by: Caolán McNamara <caolanm@redhat.com>
+---
+ include/o3tl/lru_map.hxx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/o3tl/lru_map.hxx b/include/o3tl/lru_map.hxx
+index c7132fd079c4..96fb3161782d 100644
+--- a/include/o3tl/lru_map.hxx
++++ b/include/o3tl/lru_map.hxx
+@@ -14,6 +14,7 @@
+ #include <cassert>
+ #include <list>
+ #include <unordered_map>
++#include <cstddef>
+
+ namespace o3tl
+ {
+--
+cgit v1.2.1
+
diff --git a/app-office/libreoffice/libreoffice-7.0.4.2.ebuild b/app-office/libreoffice/libreoffice-7.0.4.2.ebuild
index 1a4ef40f551c..ee1601457119 100644
--- a/app-office/libreoffice/libreoffice-7.0.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.0.4.2.ebuild
@@ -292,6 +292,9 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
"${FILESDIR}/${PN}-7.0.3.1-qt5detect.patch"
+
+ # 7.0 branch
+ "${FILESDIR}/${PN}-7.0.4.2-gcc11.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"