summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-06 18:12:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-06 18:16:42 +0100
commit6571bb8f3153ff84246ea39b85e56bc8e3af0f4b (patch)
tree8ad894137951019e790b7b961d6d4a2a51a28a5f /app-office
parentgo-module.eclass: set a reasonable default for the go build cache (diff)
downloadgentoo-6571bb8f3153ff84246ea39b85e56bc8e3af0f4b.tar.gz
gentoo-6571bb8f3153ff84246ea39b85e56bc8e3af0f4b.tar.bz2
gentoo-6571bb8f3153ff84246ea39b85e56bc8e3af0f4b.zip
app-office/unoconv: Add python3_{7,8}, drop python2_7, unused eutils
Overhaul the ebuild a bit. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/unoconv/unoconv-0.9.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/app-office/unoconv/unoconv-0.9.ebuild b/app-office/unoconv/unoconv-0.9.ebuild
index 3f411bf6cd03..53aed7fea67a 100644
--- a/app-office/unoconv/unoconv-0.9.ebuild
+++ b/app-office/unoconv/unoconv-0.9.ebuild
@@ -3,33 +3,28 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
-inherit eutils python-single-r1
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="Convert between document formats supported by Libreoffice"
+DESCRIPTION="Convert between document formats supported by LibreOffice"
HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~x86"
-IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND=""
-RDEPEND="${DEPEND}
- ${PYTHON_DEPS}
+RDEPEND="${PYTHON_DEPS}
!app-text/odt2txt
virtual/ooo
"
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
src_prepare() {
- eapply "${FILESDIR}/timeout.patch"
- eapply_user
+ default
python_fix_shebang .
}
@@ -37,6 +32,5 @@ src_compile() { :; }
src_install() {
emake -j1 doc-install install install-links DESTDIR="${D}"
-
- dodoc ChangeLog CHANGELOG.md README.adoc
+ dodoc AUTHORS ChangeLog CHANGELOG.md README.adoc
}