summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-30 13:12:18 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-30 13:23:39 +0100
commit6cdffcc4b76967cb1d5061faa994d15229ad877a (patch)
tree5c0810b2bfbe7ab7e0d8a7091012dfdb29753724 /app-office
parentapp-office/gnucash: Drop old (diff)
downloadgentoo-6cdffcc4b76967cb1d5061faa994d15229ad877a.tar.gz
gentoo-6cdffcc4b76967cb1d5061faa994d15229ad877a.tar.bz2
gentoo-6cdffcc4b76967cb1d5061faa994d15229ad877a.zip
app-office/gnucash: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/Manifest1
-rw-r--r--app-office/gnucash/gnucash-2.6.11.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/app-office/gnucash/Manifest b/app-office/gnucash/Manifest
index c7b3ca9f6edd..ecb0bc9f7372 100644
--- a/app-office/gnucash/Manifest
+++ b/app-office/gnucash/Manifest
@@ -1,2 +1,3 @@
DIST gnucash-2.6.10.tar.bz2 13513267 SHA256 a8f61651b029b54b89e63763b58ce907aeffc08ecf08320e9fb47d9c878cdb27 SHA512 b7de3cbffef3ee58f66104a097b91b946fa32c65200f2d7e2995296f034a9c9461c86b1ea2cda685df05e00a65cba4b40184b60842be94f562583a62b2120be0 WHIRLPOOL 744c8f0350e3e3840ca89d2647fae9fa7a46fdea20e6ab38c02a509df5578d6d78f79f41a56a65d1ef8e0d1c896cb8f2f14b1f0b754b5073e5879d1a792059f3
+DIST gnucash-2.6.11.tar.bz2 13626927 SHA256 516d97afa61971ca0a16f56319f3f7129db2da1a9d2c77ab7d8b4e6e9e018ac6 SHA512 f3708018f85d17377e11ce55452be7cedd6041da12f66e00047e3cdafb0190da850eb4cbb5699f01cbd79c540af7ef75b44b93c2d5929e13c2a47484741e6a7e WHIRLPOOL 3a5d78835a89718ee539a4c8a62e963172f2e41b8ce1c01ead2425f24529edc8ebc76f41f84596bf8f1438c81e687cc13ed2a4cbd72e87ca35725d88fcdf7d7f
DIST gnucash-2.6.9.tar.bz2 13230536 SHA256 cdaa61b393133e03bccce3d2740bb358d6bf590de16dd19c790c983d032d8247 SHA512 cf2846c840055c8415183028101c03a2320ef16665961e6819c4ae3a37b486b5b1e6c62adc9f7173e72c9aa68bc4c29aa35602f83639fd5cc1936a3064bf2806 WHIRLPOOL c3c5669f6214c6c47a4b51b5727bdca6247d606f376f02b9cd7e78459ad7c3fbbb7b11aa05dd3d945a192eb593e8981ad4faa8051f8257256f82cebf7d255e0d
diff --git a/app-office/gnucash/gnucash-2.6.11.ebuild b/app-office/gnucash/gnucash-2.6.11.ebuild
new file mode 100644
index 000000000000..78aa0f8afd46
--- /dev/null
+++ b/app-office/gnucash/gnucash-2.6.11.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-single-r1
+
+DESCRIPTION="A personal finance manager"
+HOMEPAGE="http://www.gnucash.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="chipcard debug +doc gnome-keyring hbci mysql ofx postgres python quotes sqlite"
+
+# FIXME: rdepend on dev-libs/qof when upstream fix their mess (see configure.ac)
+# libdbi version requirement for sqlite taken from bug #455134
+RDEPEND="
+ >=dev-libs/glib-2.32.0:2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libxml2-2.5.10:2
+ dev-libs/libxslt
+ >=dev-scheme/guile-1.8.3:12[deprecated,regex]
+ dev-scheme/guile-www
+ gnome-base/libgnomecanvas
+ >=net-libs/webkit-gtk-1.2:2
+ >=sys-libs/zlib-1.1.4
+ >=x11-libs/gtk+-2.24:2
+ >=x11-libs/goffice-0.7.0:0.8[gnome]
+ x11-libs/pango
+ gnome-keyring? ( >=app-crypt/libsecret-0.18 )
+ ofx? ( >=dev-libs/libofx-0.9.1 )
+ hbci? ( >=net-libs/aqbanking-5[gtk,ofx?]
+ sys-libs/gwenhywfar[gtk]
+ chipcard? ( sys-libs/libchipcard )
+ )
+ python? ( ${PYTHON_DEPS} )
+ quotes? ( dev-perl/DateManip
+ >=dev-perl/Finance-Quote-1.11
+ dev-perl/HTML-TableExtract )
+ sqlite? ( >=dev-db/libdbi-0.9.0
+ >=dev-db/libdbi-drivers-0.9.0[sqlite] )
+ postgres? ( dev-db/libdbi dev-db/libdbi-drivers[postgres] )
+ mysql? ( dev-db/libdbi dev-db/libdbi-drivers[mysql] )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ gnome-base/gnome-common
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+PDEPEND="doc? ( >=app-doc/gnucash-docs-2.2.0 )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Skip test that needs some locales to be present
+ sed -i -e '/test_suite_gnc_date/d' src/libqof/qof/test/test-qof.c || die
+
+ # Fix automagic on guile detection
+ # https://bugzilla.gnome.org/show_bug.cgi?id=760015
+ epatch "${FILESDIR}"/${PN}-2.6.9-automagic-guile.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ DOCS="doc/README.OFX doc/README.HBCI"
+
+ if use sqlite || use mysql || use postgres ; then
+ myconf+=" --enable-dbi"
+ else
+ myconf+=" --disable-dbi"
+ fi
+
+ # gtkmm is experimental and shouldn't be enabled, upstream bug #684166
+ gnome2_src_configure \
+ $(use_enable debug) \
+ $(use_enable gnome-keyring password-storage) \
+ $(use_enable ofx) \
+ $(use_enable hbci aqbanking) \
+ $(use_enable python) \
+ --with-guile=1.8 \
+ --disable-doxygen \
+ --disable-gtkmm \
+ --enable-locale-specific-tax \
+ --disable-error-on-warning \
+ ${myconf}
+}
+
+src_test() {
+ GUILE_WARN_DEPRECATED=no \
+ GNC_DOT_DIR="${T}"/.gnucash \
+ emake check
+}
+
+src_install() {
+ # Parallel installation fails from time to time, bug #359123
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install GNC_DOC_INSTALL_DIR=/usr/share/doc/${PF}
+
+ rm -rf "${ED}"/usr/share/doc/${PF}/{examples/,COPYING,INSTALL,*win32-bin.txt,projects.html}
+ mv "${ED}"/usr/share/doc/${PF} "${T}"/cantuseprepalldocs || die
+ dodoc "${T}"/cantuseprepalldocs/*
+}