summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-19 01:47:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-19 01:59:05 +0200
commit73309c9f2c62bf1c2b1c32814bd77d6fbfd7a3bf (patch)
tree57f4db3a6ef909628a30347a3a77b6c3cd6bd10e /app-office
parentgames-strategy/hedgewars: Drop old 0.9.25 (diff)
downloadgentoo-73309c9f2c62bf1c2b1c32814bd77d6fbfd7a3bf.tar.gz
gentoo-73309c9f2c62bf1c2b1c32814bd77d6fbfd7a3bf.tar.bz2
gentoo-73309c9f2c62bf1c2b1c32814bd77d6fbfd7a3bf.zip
app-office/libreoffice: Fix build with >=dev-db/mysql-connector-c-8
Thanks-to: Peter Levine <plevine457@gmail.com> Closes: https://bugs.gentoo.org/692422 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-6.3.2.2-mysql-connector-c-8.patch45
-rw-r--r--app-office/libreoffice/libreoffice-6.3.2.2.ebuild3
-rw-r--r--app-office/libreoffice/libreoffice-6.3.9999.ebuild3
3 files changed, 51 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-6.3.2.2-mysql-connector-c-8.patch b/app-office/libreoffice/files/libreoffice-6.3.2.2-mysql-connector-c-8.patch
new file mode 100644
index 000000000000..677ba3995753
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.3.2.2-mysql-connector-c-8.patch
@@ -0,0 +1,45 @@
+From 5917ba8bc645a2b105ec089101b8a664481b5b61 Mon Sep 17 00:00:00 2001
+From: Peter Levine <plevine457@gmail.com>
+Date: Thu, 17 Oct 2019 23:08:57 -0400
+Subject: Fix building against MySQL Connector/C 8
+
+In MySQL Connector/C 8, my_bool is replaced by bool. It was
+previously defined as char. When building against
+MySQL Connector/C 8, this leads to type punning build errors.
+Redefine affected members of struct BindMetaData as bool if using
+version 8 of greater. Otherwise, default to char.
+
+Change-Id: If12b975d95afae86502867cb334cb4195802f91d
+Reviewed-on: https://gerrit.libreoffice.org/81002
+Reviewed-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
+Tested-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
+---
+ .../source/drivers/mysqlc/mysqlc_preparedstatement.hxx | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx b/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx
+index 1df2c70..3450473 100644
+--- a/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx
++++ b/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx
+@@ -39,11 +39,17 @@ using ::com::sun::star::uno::Reference;
+ using ::com::sun::star::uno::RuntimeException;
+ using ::com::sun::star::uno::Type;
+
++#if defined MYSQL_VERSION_ID && (MYSQL_VERSION_ID >= 80000)
++using my_bool = bool;
++#else
++using my_bool = char;
++#endif
++
+ struct BindMetaData
+ {
+- char is_null = 0;
++ my_bool is_null = 0;
+ unsigned long length = 0;
+- char error = 0;
++ my_bool error = 0;
+ };
+
+ typedef ::cppu::ImplHelper5<css::sdbc::XPreparedStatement, css::sdbc::XParameters,
+--
+cgit v1.1
diff --git a/app-office/libreoffice/libreoffice-6.3.2.2.ebuild b/app-office/libreoffice/libreoffice-6.3.2.2.ebuild
index 6d7145dfa932..0233e28a4fb1 100644
--- a/app-office/libreoffice/libreoffice-6.3.2.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.3.2.2.ebuild
@@ -250,6 +250,9 @@ PATCHES=(
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
+
+ # master branch
+ "${FILESDIR}/${P}-mysql-connector-c-8.patch" # bug #692422
)
S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/app-office/libreoffice/libreoffice-6.3.9999.ebuild b/app-office/libreoffice/libreoffice-6.3.9999.ebuild
index 6d7145dfa932..f66047b35ff3 100644
--- a/app-office/libreoffice/libreoffice-6.3.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.3.9999.ebuild
@@ -250,6 +250,9 @@ PATCHES=(
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
+
+ # master branch
+ "${FILESDIR}/${PN}-6.3.2.2-mysql-connector-c-8.patch" # bug #692422
)
S="${WORKDIR}/${PN}-${MY_PV}"