summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 14:48:14 +0000
committerSam James <sam@gentoo.org>2021-02-27 15:12:38 +0000
commit7a7835a8ef07544cbd633b4c7793c4b1518a505d (patch)
tree98817d77f76eae6e885f36e88d8be07cb232e02e /app-office
parentmedia-sound/teamspeak-client: drop old version (diff)
downloadgentoo-7a7835a8ef07544cbd633b4c7793c4b1518a505d.tar.gz
gentoo-7a7835a8ef07544cbd633b4c7793c4b1518a505d.tar.bz2
gentoo-7a7835a8ef07544cbd633b4c7793c4b1518a505d.zip
app-office/mdbtools: (security) bump to 0.9.2
Includes a patch rather than sed which has been sent upstream. URL: https://github.com/mdbtools/mdbtools/pull/261 Bug: https://bugs.gentoo.org/697568 Bug: https://bugs.gentoo.org/773289 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/mdbtools/Manifest1
-rw-r--r--app-office/mdbtools/files/mdbtools-0.9.2-unixODBC-respect-libdir.patch46
-rw-r--r--app-office/mdbtools/mdbtools-0.9.2.ebuild61
3 files changed, 108 insertions, 0 deletions
diff --git a/app-office/mdbtools/Manifest b/app-office/mdbtools/Manifest
index d732992432c5..b7d1d5408cec 100644
--- a/app-office/mdbtools/Manifest
+++ b/app-office/mdbtools/Manifest
@@ -1,2 +1,3 @@
DIST mdbtools-0.7.1.tar.gz 277257 BLAKE2B 3740c543b1ea2e898a96dc1a560fd83cf079d37f5d02805891c5902b75a417c9efbf421346902766017113d447b088656afbfd0297b26655aa07fce973adc216 SHA512 bbad415c59a3f54c11bcd04971220b1370046c5dfd7300d1f23e597615a1df6af850c6f767e78033676d486d87a11c72dfdb141abbee8378337c3fda9a450b75
DIST mdbtools-0.9.1.tar.gz 158762 BLAKE2B a730c1ea4efceebb494fc69eac5b94ab23088e0c496684fe027b005492168b6639ec3ebc950e09f643e4a1b50017150caee639255e5e1deb5f9a46c0969077ff SHA512 d8383c20c062a759386e80927337f8ed526914fb53095480dfe791d80fe4cc3e19e83627ca9d34986968b282b16b4c43a6302f76c55d3c2545b6e7b625d47966
+DIST mdbtools-0.9.2.tar.gz 214246 BLAKE2B f62ffae2b084e53f7222ab969aa7f57f65735281383f93aeb025cff38b32b9aa22ffffb819532f816cc45a9156f7136bd9de953b17b86817380123451d51170c SHA512 cb2bddca83eb9867b765f6fc57fb289f91ce4e2e09dd953e338c26f6c4bcfe9ddb53368c4eef6d02927e582c2e10312462b82916c2e956fa269f25a765371d8d
diff --git a/app-office/mdbtools/files/mdbtools-0.9.2-unixODBC-respect-libdir.patch b/app-office/mdbtools/files/mdbtools-0.9.2-unixODBC-respect-libdir.patch
new file mode 100644
index 000000000000..843ad8cdc152
--- /dev/null
+++ b/app-office/mdbtools/files/mdbtools-0.9.2-unixODBC-respect-libdir.patch
@@ -0,0 +1,46 @@
+https://github.com/mdbtools/mdbtools/pull/261
+https://bugs.gentoo.org/697568
+
+From 686110d2241f02b3242d02d7c4ded9509aacd0df Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 27 Feb 2021 14:33:23 +0000
+Subject: [PATCH] configure.ac: Respect --libdir for unixODBC
+
+When searching for unixODBC, we want to use
+the libdir passed in to autotools (--libdir)
+to ensure that we find the library
+for the correct ABI.
+
+It is possible that we pick up the wrong
+copy from e.g. /usr/lib/ where a 32-bit
+unixODBC copy of the library exists
+when we're in the middle of a 64-bit build.
+
+Use ${libdir} to ensure we respect
+any preferences/information given and
+search for ODBC in the right place.
+
+Note that this previously affected
+us with iODBC but that's since been
+resolved by using their
+iodbc-config binary.
+
+Bug: https://bugs.gentoo.org/697568
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c802843d..7a1f357b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -157,7 +157,7 @@ AC_ARG_WITH(unixodbc,
+ if test "$with_unixodbc"; then
+ HAVE_ODBC=true
+ ODBC_CFLAGS="-I$with_unixodbc/include"
+- ODBC_LIBS="-L$with_unixodbc/lib"
++ ODBC_LIBS="-L$with_unixodbc/$libdir"
+ CFLAGS="$CFLAGS -DUNIXODBC"
+
+ dnl SIZEOF_LONG_INT and HAVE_LONG_LONG are required by some versions of unixODBC
diff --git a/app-office/mdbtools/mdbtools-0.9.2.ebuild b/app-office/mdbtools/mdbtools-0.9.2.ebuild
new file mode 100644
index 000000000000..456255848ac7
--- /dev/null
+++ b/app-office/mdbtools/mdbtools-0.9.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Set of libraries and utilities for reading Microsoft Access database (MDB) files"
+HOMEPAGE="https://github.com/mdbtools/mdbtools"
+SRC_URI="https://github.com/brianb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="glib odbc"
+
+BDEPEND="
+ app-text/txt2man
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ glib? ( dev-libs/glib:2 )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS HACKING NEWS README.md )
+
+PATCHES=(
+ # bug #697568
+ "${FILESDIR}/${PN}-0.9.2-unixODBC-respect-libdir.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug #770019
+ sed -i -e 's/-Werror//' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable glib)
+ $(use odbc && echo "--with-unixodbc=${EPREFIX}/usr")
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}