summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-05-27 14:50:57 +0800
committerYixun Lan <dlan@gentoo.org>2016-05-27 15:16:34 +0800
commit7e2abf3aac50d90b73a873ece6f22b2e296aafba (patch)
tree0b182ca51c97fdddf9f4ff60f1314524885a16c4 /app-office
parentsys-process/criu: drop old versions (diff)
downloadgentoo-7e2abf3aac50d90b73a873ece6f22b2e296aafba.tar.gz
gentoo-7e2abf3aac50d90b73a873ece6f22b2e296aafba.tar.bz2
gentoo-7e2abf3aac50d90b73a873ece6f22b2e296aafba.zip
a pp-office/lyx: version bump 2.2.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/Manifest1
-rw-r--r--app-office/lyx/lyx-2.2.0.ebuild193
2 files changed, 194 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index 13c28d54c41b..017927470213 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -1,3 +1,4 @@
DIST lyx-2.0.8.1.tar.xz 10481988 SHA256 fa0a9c6070554e0d12d24e9b3c4a1e5fc2ee853b3fbe83e2a415635cdc973c59 SHA512 17e313d3118dfe439f5251384f2fffdb45ffef5ec515953b7af0762d35c8e156a9338de698cea91cf8b3cedca1fc08364d8f3c50c9345f304d57004af695f901 WHIRLPOOL 6a9ef2df39861d373e1c6288f5443f910632a09ed4d84e409efe06459f2f39d3c30462b3a26aafe37c5216b765882e7ab5189e7d164b71def97f50877784754c
DIST lyx-2.1.3.tar.xz 10778624 SHA256 2fd52e7e5ee372983eb6b0a7f04765cb0df6f8c1f3420081d9f7761acfc75682 SHA512 c2930d0ff1dfb7dc23e07be7141cd50c4fa023f32fc3653745b4f5031460c6fe5acfc955c0af5b3bf9505d7958b0d1e301eefd0a894bd02bb4c3f966f54332db WHIRLPOOL 818bba837ed7e63609c1067e94f3281a9d9ef2049ba1792a010372cb544e6ead8bab0ec1906f083e8fa27f8ae8145c1cf7a4772cf3952caccf5bbd2a2c1026be
DIST lyx-2.1.4.tar.xz 10928716 SHA256 d13548cf183f2fc241df8121420933702491a7460c78a0ef6dba0e9e438ef32a SHA512 7547950e3c11e88f0ccf2cacb56709f9722d4cd03a5ee751af4489f6d343e13ee6b4e0ff7b830532572975c6cc9506686ade2afa5093f765d21b4d1b9ee7339d WHIRLPOOL a5d8533902fd5dd5a696645941c532bfe35eeaf76f411798a0aafcd01674e678dd65d2c0a58af09a6739adaf80f821a2676c340a349fca61929edfc5a9389938
+DIST lyx-2.2.0.tar.xz 14640052 SHA256 d867986870e3f7451f0d4512c60d9c3c7682da59c6c638f18b731f4ad3fa7c80 SHA512 3bc6a3dcd2271d942d1d34cf5f7b7c74d1d58499d070e5b7c056ee03d5195467a4230d18a65e9a591e76655970413370fd6233495c8d3ab977270488082425df WHIRLPOOL 5cd3b13ad8852d4ed5c59a11872547f0bb602119ce2ddbc29c5f7c240b7ca091cf341c0d22ff13c63980057706abf4a35cf5d03625545f598261c98ec4292497
diff --git a/app-office/lyx/lyx-2.2.0.ebuild b/app-office/lyx/lyx-2.2.0.ebuild
new file mode 100644
index 000000000000..9958fca6a58d
--- /dev/null
+++ b/app-office/lyx/lyx-2.2.0.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit gnome2-utils eutils fdo-mime flag-o-matic font python-single-r1 toolchain-funcs
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.2.x/${MY_P}.tar.xz
+ ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.2/${MY_P}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="cups debug nls +latex monolithic-build html rtf dot docbook dia subversion rcs svg gnumeric +hunspell aspell enchant +qt4 qt5"
+
+LANGS="ar ca cs da de el en es eu fi fr gl he hu ia id it ja nb nn pl pt_BR pt_PT ro ru sk sr sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ qt4? ( !qt5 )
+ qt5? ( !qt4 )"
+
+DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
+
+COMMONDEPEND=">=dev-libs/boost-1.34:=
+ ${PYTHON_DEPS}
+ qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 dev-qt/qtsvg:4 )
+ qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5 dev-qt/qtsvg:5 )"
+
+RDEPEND="${COMMONDEPEND}
+ dev-texlive/texlive-fontsextra
+ || ( media-gfx/imagemagick[png] media-gfx/graphicsmagick[png] )
+ cups? ( net-print/cups )
+ latex? (
+ app-text/texlive
+ app-text/ghostscript-gpl
+ app-text/noweb
+ app-text/dvipng
+ dev-tex/dvipost
+ dev-tex/chktex
+ app-text/ps2eps
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-science
+ dev-texlive/texlive-genericextra
+ dev-texlive/texlive-fontsrecommended
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht[java]
+ )
+ )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( dev-vcs/subversion )
+ rcs? ( dev-vcs/rcs )
+ svg? ( || ( media-gfx/imagemagick[svg] media-gfx/graphicsmagick[svg] )
+ || ( gnome-base/librsvg media-gfx/inkscape )
+ )
+ gnumeric? ( app-office/gnumeric )
+ hunspell? ( app-text/hunspell )
+ aspell? ( app-text/aspell )
+ enchant? ( app-text/enchant )"
+
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ font_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.1-python.patch
+ sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
+ if use qt4; then
+ export QT_SELECT=qt4
+ elif use qt5; then
+ export QT_SELECT=qt5
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+ local qt_flag=""
+ if use qt4; then
+ qt_flag=""
+ elif use qt5; then
+ qt_flag="--enable-qt5"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ $(use_with hunspell) \
+ $(use_with aspell) \
+ $(use_with enchant) \
+ ${qt_flag} \
+ --without-included-boost \
+ --disable-stdlib-debug \
+ --with-packaging=posix
+}
+
+src_install() {
+ default
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind || die
+ fi
+
+ newicon -s 32 "${S}/development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
+ doicon -s 48 "${S}/lib/images/lyx.png"
+ doicon -s scalable "${S}/lib/images/lyx.svg"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx || die
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym /usr/share/myspell /usr/share/lyx/dicts
+ dosym /usr/share/myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+
+ if use latex ; then
+ texhash
+ fi
+}