summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 21:06:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 21:07:24 +0100
commit7e2afb61ddae9852e6a0834d00aabe6e8b1c8ded (patch)
tree1ad462fa14af04a195e1b1989f97f09e47a58783 /app-office
parentapp-crypt/certbot: remove acme dir correctly (diff)
downloadgentoo-7e2afb61ddae9852e6a0834d00aabe6e8b1c8ded.tar.gz
gentoo-7e2afb61ddae9852e6a0834d00aabe6e8b1c8ded.tar.bz2
gentoo-7e2afb61ddae9852e6a0834d00aabe6e8b1c8ded.zip
app-office/scribus: Switch to cmake.eclass and fix 9999
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/scribus-1.5.5.ebuild8
-rw-r--r--app-office/scribus/scribus-9999.ebuild3
2 files changed, 5 insertions, 6 deletions
diff --git a/app-office/scribus/scribus-1.5.5.ebuild b/app-office/scribus/scribus-1.5.5.ebuild
index 88bcd5cc4410..fa0caa4e2469 100644
--- a/app-office/scribus/scribus-1.5.5.ebuild
+++ b/app-office/scribus/scribus-1.5.5.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="tk?"
-inherit cmake-utils desktop flag-o-matic python-single-r1 xdg
+inherit cmake desktop flag-o-matic python-single-r1 xdg
DESCRIPTION="Desktop publishing (DTP) and layout program"
HOMEPAGE="https://www.scribus.net/"
@@ -78,7 +78,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
rm -r codegen/cheetah scribus/third_party/hyphen || die
@@ -124,11 +124,11 @@ src_configure() {
-DWITH_PODOFO=$(usex pdf)
-DWANT_NOTEMPLATES=$(usex !templates)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if ! use tk; then
rm "${ED}"/usr/share/scribus/scripts/{FontSample,CalendarWizard}.py || die
diff --git a/app-office/scribus/scribus-9999.ebuild b/app-office/scribus/scribus-9999.ebuild
index da3a47d25206..2fc0d1910082 100644
--- a/app-office/scribus/scribus-9999.ebuild
+++ b/app-office/scribus/scribus-9999.ebuild
@@ -77,8 +77,7 @@ PATCHES=(
)
src_prepare() {
- default
- _CMAKE_SRC_PREPARE_HAS_RUN=1
+ cmake_src_prepare
rm -r codegen/cheetah scribus/third_party/hyphen || die