summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2021-10-06 00:48:31 +0200
committerSam James <sam@gentoo.org>2021-10-06 02:09:22 +0100
commit977a9e516eb47bfe30028ea3b024f5a0bf43b129 (patch)
tree51ae2cd79d7444f183e5ca1eb5dc51dae85310ee /app-office
parentnet-misc/gerbera: add 1.9.2 (diff)
downloadgentoo-977a9e516eb47bfe30028ea3b024f5a0bf43b129.tar.gz
gentoo-977a9e516eb47bfe30028ea3b024f5a0bf43b129.tar.bz2
gentoo-977a9e516eb47bfe30028ea3b024f5a0bf43b129.zip
app-office/calcurse: add 4.7.1 and fix documentation
calcurse 4.7.1 is a bug-fixing release. Also updated PYTHON_COMPAT (used by /usr/bin/calcurse-{vdir,caldav}). Thanks-to: Marco Sirabella <marco@sirabella.org> Closes: https://bugs.gentoo.org/813438 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://github.com/gentoo/gentoo/pull/22498 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calcurse/Manifest1
-rw-r--r--app-office/calcurse/calcurse-4.7.1.ebuild50
-rw-r--r--app-office/calcurse/files/calcurse-4.7.1-respect-docdir.patch13
3 files changed, 64 insertions, 0 deletions
diff --git a/app-office/calcurse/Manifest b/app-office/calcurse/Manifest
index 9979b9f27f61..d435446267bd 100644
--- a/app-office/calcurse/Manifest
+++ b/app-office/calcurse/Manifest
@@ -1 +1,2 @@
DIST calcurse-4.7.0.tar.gz 699134 BLAKE2B fb50ee3d5fe6a0eebacb557ae6fdc1b49a413b35d53fd8dfb64102bd2ed963bf83f27f1e3c3f454284143d1410f18766b56792252634ad82b1b20c130364a54c SHA512 656f3e74cde923bf7bbe5aca56f0544023b69fd8ff6ac8c851bbe224bf6cbe1fb58eb141b66ba818b1382d705e1a7c82a7e20eda7a1672d513ad54749d5a2bac
+DIST calcurse-4.7.1.tar.gz 701563 BLAKE2B 438741b9e0f61438d235fa60d13816d83c19f7d1b612619fe20a78812e77657b003ad0b9416bcc766f0e38e7868b3543972ed65eee43d8f9d6b1d80ba1872091 SHA512 8b5574d2909128c745b2d6367b517c5fb04a1c451e666dc9ee0652b3793b519576af5700d4fd073de0ccd5e5dced6b69c45dbfaf98b35a99784093208512b68e
diff --git a/app-office/calcurse/calcurse-4.7.1.ebuild b/app-office/calcurse/calcurse-4.7.1.ebuild
new file mode 100644
index 000000000000..a8060b73a4a8
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/httplib2[${PYTHON_USEDEP}]')
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}"
+
+# Some tests fail, mostly those pertaining to ical, perhaps due to requiring network?
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+ "${FILESDIR}"/${PN}-4.7.1-respect-docdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+ python_setup
+ python_fix_shebang contrib/caldav/calcurse-caldav
+}
+
+src_install() {
+ # calcurse likes to read the text files uncompressed
+ docompress -x /usr/share/doc
+ default
+}
diff --git a/app-office/calcurse/files/calcurse-4.7.1-respect-docdir.patch b/app-office/calcurse/files/calcurse-4.7.1-respect-docdir.patch
new file mode 100644
index 000000000000..8619b4d8d674
--- /dev/null
+++ b/app-office/calcurse/files/calcurse-4.7.1-respect-docdir.patch
@@ -0,0 +1,13 @@
+# Gentoo bug "app-office/calcurse: Unable to find documentation"
+# https://bugs.gentoo.org/813438
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -57,8 +57,6 @@ CLEANFILES = \
+ submitting-patches.html \
+ calcurse.1
+
+-docdir = $(datadir)/doc/$(PACKAGE)
+-
+ .txt.html:
+ if HAVE_ASCIIDOC
+ $(AM_V_GEN) $(ASCIIDOC) $(ASCIIDOC_ARGS) $<