summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-07-29 10:05:25 +0200
committerUlrich Müller <ulm@gentoo.org>2020-07-29 10:08:44 +0200
commita37759ff38b7eb98cd42eff6f99277464c32fa7e (patch)
tree65287fd611f7cf6fd9165336f54f65b24cc5e51f /app-office
parentpackage.mask: Unmask games-emulation/m64py and revdep (diff)
downloadgentoo-a37759ff38b7eb98cd42eff6f99277464c32fa7e.tar.gz
gentoo-a37759ff38b7eb98cd42eff6f99277464c32fa7e.tar.bz2
gentoo-a37759ff38b7eb98cd42eff6f99277464c32fa7e.zip
app-office/lyx: Version bump to 2.3.5.2, Python 3 support.
Closes: https://bugs.gentoo.org/695014 Closes: https://bugs.gentoo.org/721962 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/Manifest1
-rw-r--r--app-office/lyx/lyx-2.3.5.2.ebuild174
2 files changed, 175 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index d86b6c2db58e..ccf54e3aac6d 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -1 +1,2 @@
DIST lyx-2.3.3.tar.xz 15998188 BLAKE2B 491732d1e567dfc8372a7dc7810cfc46cbe7e3b6a67637f772adddcff96225e174fe8c3db4c7f9e663cf3423da8b4bf08f67679874c9aaf556973ad46159a6cc SHA512 7b42df9da9f2906f626d568222e559bb921d003674d70c805657488180856a77143b2a3d073686116c95034e84fe8f58ee1ff8a74d47a40bd5fda7564335a0c3
+DIST lyx-2.3.5.2.tar.xz 16139804 BLAKE2B e6ea7b2fbec330bfe31b8f88e0a5cc25ff65991421f99b04e98d26945bba48a95f389e2a7e6023d4c9720d43f80136682eb40ac4be51799f01e038e4b0fad206 SHA512 90c5459ad0a77568d588e05a360482985988382927583b14914d6a23b788756e957d0237c18b9ab0681dfc2ad7aa34d21e97304e3a74d19ef047c38f692fba03
diff --git a/app-office/lyx/lyx-2.3.5.2.ebuild b/app-office/lyx/lyx-2.3.5.2.ebuild
new file mode 100644
index 000000000000..320b81a0f228
--- /dev/null
+++ b/app-office/lyx/lyx-2.3.5.2.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+MY_P="${P/_}"
+inherit desktop flag-o-matic font python-single-r1 qmake-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="https://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/${MY_P}.tar.xz
+ ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.3/${MY_P}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="aspell cups debug docbook dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf subversion svg l10n_he"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/mythes
+ dev-libs/boost:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-texlive/texlive-fontsextra
+ sys-apps/file
+ sys-libs/zlib
+ virtual/imagemagick-tools[png,svg?]
+ aspell? ( app-text/aspell )
+ cups? ( net-print/cups )
+ dia? ( app-office/dia )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ enchant? ( app-text/enchant:0 )
+ gnumeric? ( app-office/gnumeric )
+ html? ( dev-tex/html2latex )
+ hunspell? ( app-text/hunspell )
+ l10n_he? ( dev-tex/culmus-latex )
+ latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ app-text/ps2eps
+ app-text/texlive
+ dev-tex/chktex
+ dev-tex/dvipost
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-plaingeneric
+ || (
+ dev-tex/hevea
+ dev-tex/latex2html
+ dev-tex/tex4ht[java]
+ dev-tex/tth
+ )
+ )
+ rcs? ( dev-vcs/rcs )
+ rtf? (
+ app-text/unrtf
+ dev-tex/html2latex
+ dev-tex/latex2rtf
+ )
+ subversion? ( dev-vcs/subversion )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-qt/qtconcurrent:5
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
+
+S="${WORKDIR}/${MY_P}"
+
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ font_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS="${T}"/fonts
+
+ econf \
+ $(use_with aspell) \
+ $(use_enable debug) \
+ $(use_with enchant) \
+ $(use_with hunspell) \
+ $(use_enable monolithic-build) \
+ $(use_enable nls) \
+ --enable-qt5 \
+ --with-qt-dir=$(qt5_get_libdir)/qt5 \
+ --disable-stdlib-debug \
+ --without-included-boost \
+ --with-packaging=posix
+}
+
+src_install() {
+ default
+
+ if use l10n_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind || die
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind || die
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind
+ fi
+
+ newicon -s 32 "development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
+ doicon -s 48 "lib/images/lyx.png"
+ doicon -s scalable "lib/images/lyx.svg"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym ../myspell /usr/share/lyx/dicts
+ dosym ../myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use l10n_he || has he ${LINGUAS} || has ar ${LINGUAS} ; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ if use latex ; then
+ texhash
+ fi
+}