summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-01-08 10:47:55 +0100
committerHans de Graaff <graaff@gentoo.org>2022-01-08 12:47:04 +0100
commitdcc7ce1a92dbfc7747ce53a3eb535e7cfafe8c75 (patch)
tree8db317201c7a7b7f7c12d03d2b374e13b05bee0d /app-office
parentdev-util/rbtools: python 3.10 (diff)
downloadgentoo-dcc7ce1a92dbfc7747ce53a3eb535e7cfafe8c75.tar.gz
gentoo-dcc7ce1a92dbfc7747ce53a3eb535e7cfafe8c75.tar.bz2
gentoo-dcc7ce1a92dbfc7747ce53a3eb535e7cfafe8c75.zip
app-office/unoconv: add python 3.10
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/unoconv/unoconv-0.9.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/unoconv/unoconv-0.9.0-r1.ebuild b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..e6a52ebfc18b
--- /dev/null
+++ b/app-office/unoconv/unoconv-0.9.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-single-r1
+
+DESCRIPTION="Convert between document formats supported by LibreOffice"
+HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-text/odt2txt
+ virtual/ooo
+"
+
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake -j1 doc-install install install-links DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog CHANGELOG.md README.adoc
+}