summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-02 08:08:56 +0100
committerSam James <sam@gentoo.org>2021-05-03 17:48:57 +0100
commite34887e1a4e731bf03c27e962b217e6326aafc79 (patch)
treed81b9f8f98f4c1d16cece340421724b576a948f8 /app-office
parentmedia-libs/libass: add 0.15.1 (diff)
downloadgentoo-e34887e1a4e731bf03c27e962b217e6326aafc79.tar.gz
gentoo-e34887e1a4e731bf03c27e962b217e6326aafc79.tar.bz2
gentoo-e34887e1a4e731bf03c27e962b217e6326aafc79.zip
app-office/mdbtools: add 0.9.3
Bug: https://bugs.gentoo.org/773289 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/mdbtools/Manifest1
-rw-r--r--app-office/mdbtools/mdbtools-0.9.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-office/mdbtools/Manifest b/app-office/mdbtools/Manifest
index b7d1d5408cec..04300d1a7d94 100644
--- a/app-office/mdbtools/Manifest
+++ b/app-office/mdbtools/Manifest
@@ -1,3 +1,4 @@
DIST mdbtools-0.7.1.tar.gz 277257 BLAKE2B 3740c543b1ea2e898a96dc1a560fd83cf079d37f5d02805891c5902b75a417c9efbf421346902766017113d447b088656afbfd0297b26655aa07fce973adc216 SHA512 bbad415c59a3f54c11bcd04971220b1370046c5dfd7300d1f23e597615a1df6af850c6f767e78033676d486d87a11c72dfdb141abbee8378337c3fda9a450b75
DIST mdbtools-0.9.1.tar.gz 158762 BLAKE2B a730c1ea4efceebb494fc69eac5b94ab23088e0c496684fe027b005492168b6639ec3ebc950e09f643e4a1b50017150caee639255e5e1deb5f9a46c0969077ff SHA512 d8383c20c062a759386e80927337f8ed526914fb53095480dfe791d80fe4cc3e19e83627ca9d34986968b282b16b4c43a6302f76c55d3c2545b6e7b625d47966
DIST mdbtools-0.9.2.tar.gz 214246 BLAKE2B f62ffae2b084e53f7222ab969aa7f57f65735281383f93aeb025cff38b32b9aa22ffffb819532f816cc45a9156f7136bd9de953b17b86817380123451d51170c SHA512 cb2bddca83eb9867b765f6fc57fb289f91ce4e2e09dd953e338c26f6c4bcfe9ddb53368c4eef6d02927e582c2e10312462b82916c2e956fa269f25a765371d8d
+DIST mdbtools-0.9.3.tar.gz 214697 BLAKE2B 59aca58d11b9c513c8d5b8401423b04484657543d742e20e058e7b29e8225a2c2c3b6e5a95a61a2214a1323b1c5d80b08a71c9f9bcdbf2f35b079a7b05919841 SHA512 3ceb9e374fd638a01d087a1f5e8fb357b24f0a85a8f9c65743a78ec1d6a981fed299744610382ae525f3781e73e268de5c4bb2e48eff78e48b197e2add23587e
diff --git a/app-office/mdbtools/mdbtools-0.9.3.ebuild b/app-office/mdbtools/mdbtools-0.9.3.ebuild
new file mode 100644
index 000000000000..f23e1aadf9c6
--- /dev/null
+++ b/app-office/mdbtools/mdbtools-0.9.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Set of libraries and utilities for reading Microsoft Access database (MDB) files"
+HOMEPAGE="https://github.com/mdbtools/mdbtools"
+SRC_URI="https://github.com/brianb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="glib odbc"
+
+BDEPEND="
+ app-text/txt2man
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ virtual/libiconv
+ glib? ( dev-libs/glib:2 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS HACKING NEWS README.md )
+
+src_prepare() {
+ default
+
+ # bug #770019
+ sed -i -e 's/-Werror//' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # TODO: Make iconv optional
+
+ local myeconfargs=(
+ --disable-static
+ $(use_enable glib)
+ $(use odbc && echo "--with-unixodbc=${EPREFIX}/usr")
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}