summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-12 14:47:26 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-12 14:47:26 +0200
commitfb05734cf587eea33eda607f8a06a6154b083321 (patch)
tree5afa82513468f214d0d1079e41047c568f40ccfe /app-office
parentx11-libs/goffice: Version bump to 0.10.48 (diff)
downloadgentoo-fb05734cf587eea33eda607f8a06a6154b083321.tar.gz
gentoo-fb05734cf587eea33eda607f8a06a6154b083321.tar.bz2
gentoo-fb05734cf587eea33eda607f8a06a6154b083321.zip
app-office/gnumeric: Version bump to 1.12.48
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.48.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index ab084bf61500..68992c80af80 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1 +1,2 @@
DIST gnumeric-1.12.47.tar.xz 18309764 BLAKE2B 8b800a6749d208a445abfc7189618abb20907118f274b313cf81436ab3665d50edeab4c49b03adea505448138bd32b8d3efcd041eba54342d9fb293c574cac08 SHA512 f6298fee752b062672acc20e18388d7424719d69ce9586888f33be07ca92bbd7d99e46b98e9ab2a546d1954d3113b59a5105d46c4e8a13e65e1ae9acc38391ab
+DIST gnumeric-1.12.48.tar.xz 18329300 BLAKE2B f38fdc14dbe2b45fa3c2ebbfb94d89c85f6c04bdc95b493a760a23ba347fa99d2515f0e7fc0a2f45e31c3f2a3b0c8b425b0fb876f59215e2da76348c5dbe116a SHA512 6c17e95ecd88b43da0f4f23d9c99dad5d0016f9618570a36be5998fa84c144bb5d13749fd9c4fe0c295e3c80d70c717d09763cc9904dfc1df062b96749b73ebc
diff --git a/app-office/gnumeric/gnumeric-1.12.48.ebuild b/app-office/gnumeric/gnumeric-1.12.48.ebuild
new file mode 100644
index 000000000000..0bee6e045c87
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.48.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit gnome.org libtool python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.48:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}