summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-06-29 17:56:40 +0300
committerPatrice Clement <monsieurp@gentoo.org>2020-07-01 20:37:11 +0200
commitc535a9a038b485e8c0384736bb66be2e5f205851 (patch)
treed8e95a7bbcb7d3aa2888a39ec838a3cb1fe684bb /app-officeext
parentdev-lang/spidermonkey: don't call ar directly (diff)
downloadgentoo-c535a9a038b485e8c0384736bb66be2e5f205851.tar.gz
gentoo-c535a9a038b485e8c0384736bb66be2e5f205851.tar.bz2
gentoo-c535a9a038b485e8c0384736bb66be2e5f205851.zip
app-officeext/languagetool: version update to 5.0.
Updated license to LGPL-2.1+, migrated to EAPI7. Closes: https://bugs.gentoo.org/605518 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16485 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-officeext')
-rw-r--r--app-officeext/languagetool/Manifest1
-rw-r--r--app-officeext/languagetool/languagetool-5.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-officeext/languagetool/Manifest b/app-officeext/languagetool/Manifest
index 34356537e77f..780452695d9d 100644
--- a/app-officeext/languagetool/Manifest
+++ b/app-officeext/languagetool/Manifest
@@ -1,2 +1,3 @@
DIST LanguageTool-3.4.oxt 58043690 BLAKE2B d381d0e426619182e8e5d7469dfb18e41c7a993f1850afd1a2720199618eaaadd093f3b7efafc23601a42221e991e71820d963326618f24be4889cf55b04f5f1 SHA512 29eda8c4a26eb4da4dce68db6f962c8a8828bb0eb76aef3e31a58607aea9a15705aaccc4a1bc5366760bdb00c9133ef225291941e5873cbcc384627464eb9a8f
DIST LanguageTool-3.5.oxt 58210562 BLAKE2B 77a455a9a7950aed69c5b6ffd1bfca43b0821f6b84cfa96d5aea05b9a57995c4542e4d651e150d964173bdc1e3364b96ececeda07919db68ad04293673f02c9f SHA512 1a36c04117c473ccb812f3b216763d816ddc796869488bfcf2f36d8ab325ef1620edf148ebb8b1b1b2d62a043b5b45f738e27ff440f6f99067601828a49f0e0e
+DIST LanguageTool-5.0.oxt 141552168 BLAKE2B 040cb817150dd1cf137feadf28ca00ce6316a529709c1255438d0fa2faac3b5a516d9a48e3e3ba6bf2fedc3650050970eae6179578c5fcf005c6484c30cf408e SHA512 8493100684598aaa7c422360e0f00b5cff0c1be22aca4bee6c7e0e12d509916bc3c7f8df052b86702f6177ffffc227d1a5dbe6b2592fa1cbdb79f4666dc22c16
diff --git a/app-officeext/languagetool/languagetool-5.0.ebuild b/app-officeext/languagetool/languagetool-5.0.ebuild
new file mode 100644
index 000000000000..962894ba86e5
--- /dev/null
+++ b/app-officeext/languagetool/languagetool-5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="LanguageTool-${PV}"
+
+OFFICE_REQ_USE="java"
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Style and Grammar Checker for libreoffice"
+HOMEPAGE="https://www.languagetool.org/"
+SRC_URI="https://www.languagetool.org/download/${MY_P}.oxt"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"