summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/gtkpod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/gtkpod')
-rw-r--r--app-pda/gtkpod/Manifest2
-rw-r--r--app-pda/gtkpod/files/gtkpod-2.1.3-gold.patch15
-rw-r--r--app-pda/gtkpod/gtkpod-2.1.4.ebuild116
-rw-r--r--app-pda/gtkpod/metadata.xml12
4 files changed, 145 insertions, 0 deletions
diff --git a/app-pda/gtkpod/Manifest b/app-pda/gtkpod/Manifest
new file mode 100644
index 000000000000..eb7482895f5f
--- /dev/null
+++ b/app-pda/gtkpod/Manifest
@@ -0,0 +1,2 @@
+DIST gst-element-check-0.10.m4.xz 420 SHA256 805f798eb9fcd79fdd7a937e321a7a61b7a1ff54aa1191270ae48e84f062d7f9 SHA512 07f59b8cdd65263b7f861cafcadbc22620ac66c80ae526dbfb4b305c64680dc353c18b18f347dcf8858dfd996802690b48ab3a539c42c5a75cf4d981ae61811c WHIRLPOOL 13c237320eb684a665e0c386aee4824bb7b1799fd9fc2afcb9b3825cca575ccf8e29e022856b29571f3332cdea5f9304dccc787b3621a402e9215df2b3cb4de5
+DIST gtkpod-2.1.4.tar.gz 3721445 SHA256 ba12b35f3f24a155b68f0ffdaf4d3c5c7d1b8df04843a53306e1c83fc811dfaa SHA512 803e37729e8d0bb2e9f6a4bb00c89bdfb4a2dfeffe713808ce9a88af68dc0d017a30159a532e74dcf6b05ee50028b854d4358d84752a52d6ca4f259060501a8a WHIRLPOOL 43c8b301846caee00a01d2c8e990d431c5dfbd748796c724ea035218ffe56224f69db6c3ad01e354a6f1f83a579e169aa6f7e57345ce050fde4e22f2a0b1235c
diff --git a/app-pda/gtkpod/files/gtkpod-2.1.3-gold.patch b/app-pda/gtkpod/files/gtkpod-2.1.3-gold.patch
new file mode 100644
index 000000000000..93c9f72a3747
--- /dev/null
+++ b/app-pda/gtkpod/files/gtkpod-2.1.3-gold.patch
@@ -0,0 +1,15 @@
+ libgtkpod/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libgtkpod/Makefile.am b/libgtkpod/Makefile.am
+index 464741f..c69dac8 100644
+--- a/libgtkpod/Makefile.am
++++ b/libgtkpod/Makefile.am
+@@ -50,6 +50,7 @@ AM_CFLAGS = \
+ libgtkpod_la_LDFLAGS = $(LIBGTKPOD_LDFLAGS) -version-info $(LIBGTKPOD_SO_VERSION) -no-undefined
+ libgtkpod_la_LIBADD = \
+ $(LIBGTKPOD_LIBS) \
++ -lm \
+ @LIBOBJS@
+
+ libgtkpodincludebase = $(includedir)/gtkpod
diff --git a/app-pda/gtkpod/gtkpod-2.1.4.ebuild b/app-pda/gtkpod/gtkpod-2.1.4.ebuild
new file mode 100644
index 000000000000..6a174f5ea89f
--- /dev/null
+++ b/app-pda/gtkpod/gtkpod-2.1.4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="A graphical user interface to the Apple productline"
+HOMEPAGE="http://gtkpod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ http://dev.gentoo.org/~ssuominen/gst-element-check-0.10.m4.xz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="aac clutter curl cdr flac gstreamer mp3 vorbis webkit"
+
+# watch out for possible musicbrainz:5 compability in next version?
+COMMON_DEPEND="
+ >=dev-libs/gdl-3.6:3
+ >=dev-libs/glib-2.31
+ >=dev-libs/libxml2-2.7.7
+ >=dev-util/anjuta-3.6
+ >=media-libs/libgpod-0.8.2:=
+ >=media-libs/libid3tag-0.15
+ >=x11-libs/gtk+-3.0.8:3
+ aac? ( media-libs/faad2 )
+ clutter? ( >=media-libs/clutter-gtk-1.2:1.0 )
+ curl? ( >=net-misc/curl-7.10 )
+ flac? ( media-libs/flac )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10.25:0.10
+ >=media-libs/gst-plugins-base-0.10.25:0.10
+ cdr? (
+ >=app-cdr/brasero-3
+ media-libs/musicbrainz:3
+ )
+ )
+ mp3? ( media-sound/lame )
+ vorbis? (
+ media-libs/libvorbis
+ media-sound/vorbis-tools
+ )
+ webkit? ( >=net-libs/webkit-gtk-1.3:3 )"
+# to pull in at least -flac and -vorbis plugins , but others at the same time
+RDEPEND="${COMMON_DEPEND}
+ gstreamer? ( media-plugins/gst-plugins-meta:0.10 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/os-headers
+ virtual/pkgconfig"
+REQUIRED_USE="cdr? ( gstreamer )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.3-gold.patch
+
+ sed -i -e 's:python:python2:' scripts/sync-palm-jppy.py || die
+ # punt deprecated flags for forward compability
+ # use more widely used musicbrainz:3 instead of :4
+ # use AC_CONFIG_HEADERS for automake-1.13 compability wrt #467598
+ sed -e 's:CLEANLINESS_FLAGS=".*:CLEANLINESS_FLAGS="":' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e '/PKG_CHECK_MODULES/s:libmusicbrainz4:&sLoT4iSdEpReCaTeD:' \
+ -i configure.ac || die
+ # /path/to/install: '/path/to/app-pda/gtkpod-2.1.2_beta2/image/usr/share/gtkpod/data/rhythmbox.gep’: File exists
+ sed -i -e '/^dist_profiles_DATA/s:=.*:=:' plugins/sjcd/data/Makefile.am || die
+
+ # m4dir for gst-element-check-0.10.m4
+ AT_M4DIR=${WORKDIR} eautoreconf
+}
+
+src_configure() {
+ export GST_INSPECT=true #420279
+
+ econf \
+ --disable-static \
+ $(use_enable webkit plugin-coverweb) \
+ $(use_enable clutter plugin-clarity) \
+ $(use_enable gstreamer plugin-media-player) \
+ $(use_enable cdr plugin-sjcd) \
+ $(use_with curl) \
+ $(use_with vorbis ogg) \
+ $(use_with flac) \
+ $(use_with aac mp4)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF}/html \
+ figuresdir=/usr/share/doc/${PF}/html/figures \
+ install
+
+ prune_libtool_files --all
+
+ dodoc AUTHORS ChangeLog NEWS README TODO TROUBLESHOOTING
+ rm -f "${ED}"/usr/share/gtkpod/data/{AUTHORS,COPYING} || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/app-pda/gtkpod/metadata.xml b/app-pda/gtkpod/metadata.xml
new file mode 100644
index 000000000000..cb7708a4a1eb
--- /dev/null
+++ b/app-pda/gtkpod/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <use>
+ <flag name="clutter">Enable clutter support for displaying coverart</flag>
+ <flag name="webkit">Enable webkit support for finding coverart</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">gtkpod</remote-id>
+ </upstream>
+</pkgmetadata>