summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/libopensync/libopensync-0.39-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/libopensync/libopensync-0.39-r1.ebuild')
-rw-r--r--app-pda/libopensync/libopensync-0.39-r1.ebuild126
1 files changed, 126 insertions, 0 deletions
diff --git a/app-pda/libopensync/libopensync-0.39-r1.ebuild b/app-pda/libopensync/libopensync-0.39-r1.ebuild
new file mode 100644
index 000000000000..a7097518e2ff
--- /dev/null
+++ b/app-pda/libopensync/libopensync-0.39-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit cmake-utils python
+
+DESCRIPTION="OpenSync synchronisation framework library"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="debug doc python" # test
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.12:2
+ dev-libs/libxml2
+ dev-libs/libxslt"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )
+ python? ( >=dev-lang/swig-1.3.17 )"
+# test? ( >=dev-libs/check-0.9.2 )"
+
+DOCS="AUTHORS CODING ChangeLog README"
+
+# Tests don't pass
+RESTRICT="test"
+
+src_prepare() {
+ # Has hardcoded python versions, use the module shipped with cmake instead
+ # bug #276220
+ rm "${S}"/cmake/modules/FindPythonLibs.cmake
+
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DCMAKE_SKIP_RPATH=ON
+ $(cmake-utils_use_build doc DOCUMENTATION)
+ $(cmake-utils_use_enable python WRAPPER)
+ $(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
+ $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
+ $(cmake-utils_use debug OPENSYNC_TRACE)"
+# $(cmake-utils_use test OPENSYNC_UNITTESTS)"
+
+ do_configure() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ # since we're using cmake's FindPythonLibs PYTHON_VERSION is
+ # not defined
+ sed -i -e "s:\${PYTHON_VERSION}:${PYTHON_ABI}:g" \
+ "${CMAKE_BUILD_DIR}"/wrapper/CMakeLists.txt
+ fi
+ cmake-utils_src_configure || die
+ }
+
+ use python \
+ && python_execute_function -s do_configure \
+ || do_configure
+}
+
+src_compile() {
+ do_compile() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ fi
+ cmake-utils_src_compile || die
+ }
+
+ use python \
+ && python_execute_function -s do_compile \
+ || do_compile
+
+ if use doc ; then
+ cmake-utils_src_make DoxygenDoc || die
+ fi
+}
+
+# TODO - fix
+src_test() {
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+
+ if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
+ die "Make test failed. See above for details."
+ fi
+
+ popd > /dev/null
+}
+
+src_install() {
+ do_install() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ fi
+ cmake-utils_src_install || die
+ }
+
+ use python \
+ && python_execute_function -s do_install \
+ || do_install
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ dohtml docs/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ elog "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
+ elog "the older app-pda/msynctool."
+}