summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/p3nfs/p3nfs-5.19-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/p3nfs/p3nfs-5.19-r2.ebuild')
-rw-r--r--app-pda/p3nfs/p3nfs-5.19-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-pda/p3nfs/p3nfs-5.19-r2.ebuild b/app-pda/p3nfs/p3nfs-5.19-r2.ebuild
new file mode 100644
index 000000000000..2ec44cfa45e6
--- /dev/null
+++ b/app-pda/p3nfs/p3nfs-5.19-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Symbian to Unix and Linux communication program"
+HOMEPAGE="http://www.koeniglich.de/p3nfs.html"
+SRC_URI="http://www.koeniglich.de/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( net-nds/portmap net-nds/rpcbind )"
+
+src_prepare() {
+ sed -i "s:.*cd client/epoc32.*:#&:" "${S}/Makefile.in" || die
+ # bug #314971
+ epatch "${FILESDIR}/${P}-set-default-tty.patch"
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing # fix QA issues
+ sed -i "s:\$(LDFLAGS):${LDFLAGS}:" "${S}/server/Makefile.in" || die
+
+ econf || die "econf failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -I." || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" install || die "emake install failed"
+
+ dodoc README
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to install one of the nfsapp-*.sis clients on your"
+ elog "Symbian device to be able to mount it's filesystems."
+ elog
+ elog "Make sure to have portmap or rpcbind service running"
+ elog "before you start the p3nfsd server."
+ elog
+}