summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-01 11:44:30 +0100
committerBen Kohler <bkohler@gentoo.org>2021-02-09 10:59:20 -0600
commit7d978c2ca9e5872480869637b4dbccfbf9b25569 (patch)
tree0d872e4dc9018c5eccedf7a9248a4d72e60aa36c /app-pda
parentapp-office/magicpoint: Fix build with gcc-10 (diff)
downloadgentoo-7d978c2ca9e5872480869637b4dbccfbf9b25569.tar.gz
gentoo-7d978c2ca9e5872480869637b4dbccfbf9b25569.tar.bz2
gentoo-7d978c2ca9e5872480869637b4dbccfbf9b25569.zip
app-pda/jpilot: Port to EAPI 7
* Fix build with gcc-10 Closes: https://bugs.gentoo.org/709790 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/jpilot/files/jpilot-1.8.2-fno-common.patch36
-rw-r--r--app-pda/jpilot/jpilot-1.8.2-r1.ebuild16
2 files changed, 45 insertions, 7 deletions
diff --git a/app-pda/jpilot/files/jpilot-1.8.2-fno-common.patch b/app-pda/jpilot/files/jpilot-1.8.2-fno-common.patch
new file mode 100644
index 000000000000..c6cf3665fdde
--- /dev/null
+++ b/app-pda/jpilot/files/jpilot-1.8.2-fno-common.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/709790
+--- a/jpilot-dump.c
++++ b/jpilot-dump.c
+@@ -76,7 +76,7 @@ const char *formatT;
+ * this code but must be instantiated for the code to compile.
+ * The same is true of the functions which are only used in GUI mode. */
+ pid_t jpilot_master_pid = -1;
+-int pipe_to_parent;
++extern int pipe_to_parent;
+ GtkWidget *glob_dialog;
+ GtkWidget *glob_date_label;
+ gint glob_date_timer_tag;
+--- a/jpilot-sync.c
++++ b/jpilot-sync.c
+@@ -37,7 +37,8 @@
+ #include "otherconv.h"
+
+ /******************************* Global vars **********************************/
+-int pipe_to_parent, pipe_from_parent;
++extern int pipe_to_parent;
++int pipe_from_parent;
+ pid_t glob_child_pid;
+ unsigned char skip_plugins;
+
+--- a/jpilot.c
++++ b/jpilot.c
+@@ -84,7 +84,8 @@
+ /* #define PIPE_DEBUG */
+ /******************************* Global vars **********************************/
+ /* Application-wide globals */
+-int pipe_from_child, pipe_to_parent;
++extern int pipe_to_parent;
++int pipe_from_child;
+ int pipe_from_parent, pipe_to_child;
+ /* Main GTK window for application */
+ GtkWidget *window;
diff --git a/app-pda/jpilot/jpilot-1.8.2-r1.ebuild b/app-pda/jpilot/jpilot-1.8.2-r1.ebuild
index e7518b102d75..168934bd8aef 100644
--- a/app-pda/jpilot/jpilot-1.8.2-r1.ebuild
+++ b/app-pda/jpilot/jpilot-1.8.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -18,7 +18,8 @@ RDEPEND="
app-pda/pilot-link
dev-libs/libgcrypt:0=
x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
nls? (
dev-util/intltool
sys-devel/gettext
@@ -26,8 +27,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-1.8.2-qa-desktop-file.patch
- "${FILESDIR}"/${PN}-1.8.2-fix-paths.patch
+ "${FILESDIR}"/${P}-qa-desktop-file.patch
+ "${FILESDIR}"/${P}-fix-paths.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_prepare() {
@@ -45,6 +47,6 @@ src_install() {
default
docompress -x /usr/share/doc/${PF}/icons
- # .la files for plugins are useless
- find "${D}" -name '*.la' -delete || die
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}