summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-08-02 22:26:30 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-08-02 22:29:02 -0700
commitfd1ce6c032d0628bf02c3a712c62398612ab6474 (patch)
tree2f4146aef5ad370b237111808e555e9d676c41a2 /app-pda
parentdev-ruby/nagios_analyzer: add ruby27 (diff)
downloadgentoo-fd1ce6c032d0628bf02c3a712c62398612ab6474.tar.gz
gentoo-fd1ce6c032d0628bf02c3a712c62398612ab6474.tar.bz2
gentoo-fd1ce6c032d0628bf02c3a712c62398612ab6474.zip
app-pda/pilot-link: minor cleanup
- Drop python & java bindings - handle -Werror=foo from sandbox testing - reference new non-official upstream - P.S. This still worked for me as of 2019; probably still works, but hardware limitations in testing. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Closes: https://bugs.gentoo.org/show_bug.cgi?id=735238 Closes: https://bugs.gentoo.org/show_bug.cgi?id=714828 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.5-Werror-args.patch18
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.5-r3.ebuild105
2 files changed, 123 insertions, 0 deletions
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.5-Werror-args.patch b/app-pda/pilot-link/files/pilot-link-0.12.5-Werror-args.patch
new file mode 100644
index 000000000000..5e6b939d0100
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.5-Werror-args.patch
@@ -0,0 +1,18 @@
+-Werror can have args now, but didn't when this code was originally written.
+
+Closes: https://bugs.gentoo.org/show_bug.cgi?id=714828
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+--- pilot-link-0.12.5.orig/configure.ac 2020-08-02 21:58:12.481559328 -0700
++++ pilot-link-0.12.5/configure.ac 2020-08-02 22:02:49.641291824 -0700
+@@ -63,8 +63,8 @@
+ dnl Eat -Werror so configure will run properly, if the user provided it
+ enable_werror=no
+ save_CFLAGS="$CFLAGS"
+-CFLAGS=`echo $save_CFLAGS | sed -e s/-Werror//g`
+-CXXFLAGS=`echo $save_CXXFLAGS | sed -e s/-Werror//g`
++CFLAGS=`echo $save_CFLAGS | sed -r -e 's/-Werror(=[^[:space:]]+)?//g'`
++CXXFLAGS=`echo $save_CXXFLAGS | sed -r -e 's/-Werror(=[^[:space:]]+)?//g'`
+ if test "x$CFLAGS" != "x$save_CFLAGS"; then
+ dnl -Werror was set; treat it as implicit --enable-werror below
+ enable_werror="yes"
diff --git a/app-pda/pilot-link/pilot-link-0.12.5-r3.ebuild b/app-pda/pilot-link/pilot-link-0.12.5-r3.ebuild
new file mode 100644
index 000000000000..f28d43f7d288
--- /dev/null
+++ b/app-pda/pilot-link/pilot-link-0.12.5-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools perl-module
+
+DESCRIPTION="Suite of tools for moving data between a Palm device and a desktop"
+# this is a new mirror; the distfile has the same content inside the tarball,
+# but the tarball itself doesn't match due to recompression and Git
+# indirection.
+HOMEPAGE="https://github.com/jichu4n/pilot-link"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/${P}-gentoo-patchset.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bluetooth debug perl png static-libs threads usb"
+
+COMMON_DEPEND="
+ dev-libs/popt
+ >=sys-libs/ncurses-5.7-r7:0=
+ >=sys-libs/readline-6:0=
+ virtual/libiconv
+ bluetooth? ( net-wireless/bluez )
+ perl? ( >=dev-lang/perl-5.12 )
+ png? ( media-libs/libpng:0= )
+ usb? ( virtual/libusb:0 )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+RESTRICT="test" #672872
+
+src_prepare() {
+ default
+
+ eapply -p0 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.3-java-install.patch
+ eapply -p0 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.3-respect-javacflags.patch
+ eapply -p0 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.2-werror_194921.patch
+ eapply -p1 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.2-threads.patch
+ eapply -p0 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.3-libpng14.patch
+ eapply -p1 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.3-png.patch
+ eapply -p0 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.3-distutils.patch
+ eapply -p1 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.3-libusb-compat-usb_open.patch
+ eapply -p1 "${WORKDIR}/${P}-gentoo-patchset"/${PN}-0.12.5-perl514.patch
+ eapply -p1 "${FILESDIR}"/${PN}-0.12.5-Werror-args.patch
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467600
+
+ AT_M4DIR="m4" eautoreconf
+
+}
+
+src_configure() {
+ # tcl/tk support is disabled as per upstream request.
+ # readline is not really optional, bug #626504
+ # Does not build with Java 8
+ # Does not build with Python 3, bug 735238
+ econf \
+ --includedir="${EPREFIX}"/usr/include/libpisock \
+ $(use_enable static-libs static) \
+ --enable-conduits \
+ --with-readline \
+ $(use_enable threads) \
+ $(use_enable usb libusb) \
+ $(use_enable debug) \
+ $(use_with png libpng) \
+ $(use_with bluetooth bluez) \
+ $(use_with perl) \
+ --without-java \
+ --without-tcl \
+ --without-python
+}
+
+src_compile() {
+ emake
+
+ if use perl; then
+ cd "${S}"/bindings/Perl
+ perl-module_src_configure
+ local mymake=( OTHERLDFLAGS="${LDFLAGS} -L../../libpisock/.libs -lpisock" ) #308629
+ perl-module_src_compile
+ fi
+
+ # Python 2.0 only; not enabled anymore
+ # bug 735238
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README doc/{README*,TODO}
+
+ if use perl; then
+ cd "${S}"/bindings/Perl
+ perl-module_src_install
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ perl_set_version
+}