summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2021-11-02 14:35:52 -0400
committerRichard Freeman <rich0@gentoo.org>2021-11-02 14:42:38 -0400
commit58ade081f7b2d8b1c957be7c6e3d87c0e83360d4 (patch)
tree48f0439ad584e20efcdb21a35993fc343a2fe730 /app-portage/cfg-update
parentmail-mta/postfix: bump to 3.7_pre20211030 (diff)
downloadgentoo-58ade081f7b2d8b1c957be7c6e3d87c0e83360d4.tar.gz
gentoo-58ade081f7b2d8b1c957be7c6e3d87c0e83360d4.tar.bz2
gentoo-58ade081f7b2d8b1c957be7c6e3d87c0e83360d4.zip
app-portage/cfg-update: EAPI bump and set ALLARCHES
Closes: https://bugs.gentoo.org/819753 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-portage/cfg-update')
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild102
-rw-r--r--app-portage/cfg-update/metadata.xml1
2 files changed, 103 insertions, 0 deletions
diff --git a/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild b/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild
new file mode 100644
index 000000000000..0fae01aee1f3
--- /dev/null
+++ b/app-portage/cfg-update/cfg-update-1.8.9-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Easy to use GUI & CLI alternative for etc-update"
+HOMEPAGE="https://github.com/rich0/cfg-update"
+SRC_URI="https://github.com/rich0/cfg-update/archive/${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="X"
+
+RDEPEND="
+ dev-perl/TermReadKey
+ X? (
+ >=x11-misc/sux-1.0
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/rich0-cfg-update-2f10786"
+
+pkg_prerm() {
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Disabling portage hook"
+ cfg-update --ebuild --disable-portage-hook
+ eend $?
+ ebegin "Disabling paludis hook"
+ cfg-update --ebuild --disable-paludis-hook
+ eend $?
+ fi
+}
+
+pkg_postrm() {
+ echo
+ ewarn "If you want to permanently remove cfg-update from your system"
+ ewarn "you should remove the index file /var/lib/cfg-update/checksum.index"
+ echo
+}
+
+src_install() {
+ dobin \
+ cfg-update emerge_with_indexing_for_cfg-update \
+ emerge_with_indexing_for_cfg-update_phphelper \
+ cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
+ insinto /usr/lib/cfg-update
+ doins cfg-update cfg-update_indexing test.tgz
+ dodoc ChangeLog
+ doman *.8
+ insinto /etc
+ doins cfg-update.conf cfg-update.hosts
+ keepdir /var/lib/cfg-update
+}
+
+pkg_postinst() {
+ if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
+ && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
+ then
+ ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
+ mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
+ "${ROOT}"/var/lib/cfg-update/checksum.index
+ eend $?
+ fi
+
+ if [[ -e "${ROOT}"/usr/bin/paludis ]]
+ then
+ echo
+ ewarn "If you have used Paludis version <0.20.0 on your system, chances are"
+ ewarn "that you have some corrupted CONTENTS files on your system..."
+ echo
+ ewarn "Please run: cfg-update --check-packages"
+ echo
+ ewarn "The above command will check all packages installed with Paludis and"
+ ewarn "will output a list of packages that need to be re-installed with"
+ ewarn "Paludis 0.20.0 or higher. If you do not re-install these packages"
+ ewarn "you risk losing your custom settings when updating configuration"
+ ewarn "files, that belong to these packages, with cfg-update!"
+ echo
+ fi
+
+ if [[ ${ROOT} == / ]]
+ then
+ ebegin "Moving backups to /var/lib/cfg-update/backups"
+ /usr/bin/cfg-update --ebuild --move-backups
+ eend $?
+ fi
+
+ echo
+ einfo "If this is a first time install, please check the configuration"
+ einfo "in /etc/cfg-update.conf before using cfg-update:"
+ echo
+ einfo "If your system does not have an X-server installed you need to"
+ einfo "change the MERGE_TOOL to sdiff, imediff2 or vimdiff."
+ einfo "If you have X installed, set MERGE_TOOL to your favorite GUI tool:"
+ einfo "xxdiff, beediff, kdiff3, meld (default), gtkdiff, gvimdiff, tkdiff"
+ echo
+ einfo "TIP: to maximize the chances of future automatic updates, run:"
+ einfo "cfg-update --optimize-backups"
+ echo
+}
diff --git a/app-portage/cfg-update/metadata.xml b/app-portage/cfg-update/metadata.xml
index 7ab5e1a53ddd..7e1aa3ceff28 100644
--- a/app-portage/cfg-update/metadata.xml
+++ b/app-portage/cfg-update/metadata.xml
@@ -7,4 +7,5 @@
<upstream>
<remote-id type="github">rich0/cfg-update</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>