summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2015-08-29 14:25:23 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2015-08-29 14:26:05 +0200
commit6e3a08ff88dc49c607d74d4997d8b7fd3e48fa6a (patch)
treedd6d40322130522fae61bc48456bacd63b675f8d /app-portage/conf-update/conf-update-1.0.3.ebuild
parentdev-lisp/sbcl: update BV_AMD64 in sbcl-1.2.14 (diff)
downloadgentoo-6e3a08ff88dc49c607d74d4997d8b7fd3e48fa6a.tar.gz
gentoo-6e3a08ff88dc49c607d74d4997d8b7fd3e48fa6a.tar.bz2
gentoo-6e3a08ff88dc49c607d74d4997d8b7fd3e48fa6a.zip
app-portage/conf-update: bump to version 1.0.3
Gentoo-Bug: #527326 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-portage/conf-update/conf-update-1.0.3.ebuild')
-rw-r--r--app-portage/conf-update/conf-update-1.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/conf-update/conf-update-1.0.3.ebuild b/app-portage/conf-update/conf-update-1.0.3.ebuild
new file mode 100644
index 000000000000..97800314e5f2
--- /dev/null
+++ b/app-portage/conf-update/conf-update-1.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="${PN} is a ncurses-based config management utility"
+HOMEPAGE="https://gitweb.gentoo.org/proj/conf-update.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${PF}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="colordiff"
+
+RDEPEND=">=dev-libs/glib-2.6
+ sys-libs/ncurses:0
+ dev-libs/openssl:0
+ colordiff? ( app-misc/colordiff )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/\$Rev:.*\\$/${PVR}/" "${S}"/"${PN}".h || die
+ if use colordiff ; then
+ sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf \ die 'colordiff-sed failed'
+ fi
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}