summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-11-23 11:19:42 +0100
committerSebastian Pipping <sping@gentoo.org>2020-11-23 11:20:31 +0100
commitec8411dbeac3f9473dc45fcee102b2ffb9c18cf5 (patch)
tree00804a07724e1b4c5c249c175cf1dfdb468d3bf3 /app-portage/elogv/elogv-0.7.9.ebuild
parentprofiles/prefix/darwin/macos: unmask GCC in gcc feature (diff)
downloadgentoo-ec8411dbeac3f9473dc45fcee102b2ffb9c18cf5.tar.gz
gentoo-ec8411dbeac3f9473dc45fcee102b2ffb9c18cf5.tar.bz2
gentoo-ec8411dbeac3f9473dc45fcee102b2ffb9c18cf5.zip
app-portage/elogv: 0.7.9 + drop old + sync SRC_URI
Bug: https://bugs.gentoo.org/756019 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'app-portage/elogv/elogv-0.7.9.ebuild')
-rw-r--r--app-portage/elogv/elogv-0.7.9.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-portage/elogv/elogv-0.7.9.ebuild b/app-portage/elogv/elogv-0.7.9.ebuild
new file mode 100644
index 000000000000..7295a4ba514b
--- /dev/null
+++ b/app-portage/elogv/elogv-0.7.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="ncurses"
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Curses based utility to parse the contents of elogs created by Portage"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elogv.git/"
+SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+DOCS=( README )
+
+src_install() {
+ distutils-r1_src_install
+
+ # unset LINGUAS => install all languages
+ # empty LINGUAS => install none
+ local i
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(ls "${ED}"/usr/share/locale/) ; do
+ if ! has ${i} ${LINGUAS} ; then
+ rm -rf "${ED}"/usr/share/{locale,man}/${i}
+ fi
+ done
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use this software, you need to activate"
+ elog "Portage's elog features. Required is"
+ elog " PORTAGE_ELOG_SYSTEM=\"save\" "
+ elog "and at least one out of "
+ elog " PORTAGE_ELOG_CLASSES=\"warn error info log qa\""
+ elog "More information on the elog system can be found"
+ elog "in ${EPREFIX}/usr/share/portage/config/make.conf.example"
+ elog
+ elog "To operate properly this software needs the directory"
+ elog "${PORT_LOGDIR:-${EPREFIX}/var/log/portage}/elog created, belonging to group portage."
+ elog "To start the software as a user, add yourself to the portage"
+ elog "group."
+ elog
+}