summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-26 09:14:41 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-26 09:16:58 +0200
commit6df30110505cedaa7f456c6d4cdb7d259d025e2f (patch)
treee1e99dd36b1bcfb82882960ce7dee150ee820e84 /app-portage/elt-patches
parentapp-misc/elasticsearch: remove force flag from rm. (diff)
downloadgentoo-6df30110505cedaa7f456c6d4cdb7d259d025e2f.tar.gz
gentoo-6df30110505cedaa7f456c6d4cdb7d259d025e2f.tar.bz2
gentoo-6df30110505cedaa7f456c6d4cdb7d259d025e2f.zip
app-portage/elt-patches: Bump to fix FreeBSD tools, #628882
Diffstat (limited to 'app-portage/elt-patches')
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20170826.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index b28be85a1f92..f51d464c4237 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -1,3 +1,4 @@
DIST elt-patches-20170317.tar.xz 23356 SHA256 24d2665ba560d01160b955ecf46a17433ee879960e3d914698be170b6698dad4 SHA512 28da9a214cd2bccebad45f464a414fedf80fc6b497d1f6b8f30a0a67570a614065ef67ce43316872d94a144de1a154ecd164a47009ebcd7d39128ccc2dd39618 WHIRLPOOL 944e2a1a92485a93b1b236047d8c6394c76b8b68242f8bf3f683511c0357ee351a2823e77707e2737ea247873fd88287120c3fc3af4ed28488bfafb13a0b163b
DIST elt-patches-20170422.tar.xz 27864 SHA256 56c5391b8c6958bca081d1eead516917ac6571da283862b2468fe0e2eb33682c SHA512 90867925f797ec815cfd8f45655cbc0bdc5f46e1a84792988ca76aaed97489907a926acf8f50c0499c56f6e70ea7081732f71c74a8d49bf24a6d265a0a4202dc WHIRLPOOL 11e2aa4f74e8648730e7d541d6061ec72f4f2ef40c205a863a381f972931e9441cc2110c7e8d3f71899ffc08d9857a5afa01438d2d2080cc9f2d394cf84c00f5
DIST elt-patches-20170815.tar.xz 27864 SHA256 caf05e2b3bdf1dfc4188a27c703dc68d66d51ea4274edc6a6ebf9918cf1b2340 SHA512 deba10767b6a8cb5e8139e6f47a30e6f8a4a9312adb1d3e0199df24321d89601915fc91003da2d14fda679e7cbd30a4d4cf39d94ba57bce06432eefc168650dd WHIRLPOOL dcf892154407238cbe7874a1d2b976b8bf8260ab47a18cd8d6e543d98fa47442d83cfefca9431a2e4eebae5156f5e31e4d976831558faff8a79da251d45686f2
+DIST elt-patches-20170826.tar.xz 27948 SHA256 dcaf265f7a3167148e95e4ccf3334f02d4685abc05bc0d867f4ce83428a74cf9 SHA512 b10099eabbade6ee27d2c63c744e46e49d64bf66166fb56a03614e87c8434b0c0c0f1ad31cc34228627601abcf67026c8143949a51d2426828b6b3a126c1ea50 WHIRLPOOL b63ab31255fd3695f95f8a22e20995731a0592b3ea21ea7f0128b33d3ed03d9abeb930362f0974b11ff30b31357bfd2a345524b0d45ecda49e1315754329da4a
diff --git a/app-portage/elt-patches/elt-patches-20170826.ebuild b/app-portage/elt-patches/elt-patches-20170826.ebuild
new file mode 100644
index 000000000000..84ee7fc57803
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20170826.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~x86-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND="sys-apps/gentoo-functions"
+DEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX%/}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX%/}" install
+}