summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-22 09:14:14 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-11 15:35:07 +0200
commitafaaa45339955be5d08d8919aee22c00b4d8d751 (patch)
tree300accfeca5cd6dae057382c3ad6e4c88bbbb92e /app-portage/elt-patches
parentsys-apps/ipmiutil: Removed old. (diff)
downloadgentoo-afaaa45339955be5d08d8919aee22c00b4d8d751.tar.gz
gentoo-afaaa45339955be5d08d8919aee22c00b4d8d751.tar.bz2
gentoo-afaaa45339955be5d08d8919aee22c00b4d8d751.zip
app-portage/elt-patches: New release with 'eltpatch' script
New release with the 'eltpatch' script that moves libtool.eclass code to the package, ensuring it is kept in sync with the patches.
Diffstat (limited to 'app-portage/elt-patches')
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20170422.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index 9080c4deef34..a9b526074ec9 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -1 +1,2 @@
DIST elt-patches-20170317.tar.xz 23356 SHA256 24d2665ba560d01160b955ecf46a17433ee879960e3d914698be170b6698dad4 SHA512 28da9a214cd2bccebad45f464a414fedf80fc6b497d1f6b8f30a0a67570a614065ef67ce43316872d94a144de1a154ecd164a47009ebcd7d39128ccc2dd39618 WHIRLPOOL 944e2a1a92485a93b1b236047d8c6394c76b8b68242f8bf3f683511c0357ee351a2823e77707e2737ea247873fd88287120c3fc3af4ed28488bfafb13a0b163b
+DIST elt-patches-20170422.tar.xz 27864 SHA256 56c5391b8c6958bca081d1eead516917ac6571da283862b2468fe0e2eb33682c SHA512 90867925f797ec815cfd8f45655cbc0bdc5f46e1a84792988ca76aaed97489907a926acf8f50c0499c56f6e70ea7081732f71c74a8d49bf24a6d265a0a4202dc WHIRLPOOL 11e2aa4f74e8648730e7d541d6061ec72f4f2ef40c205a863a381f972931e9441cc2110c7e8d3f71899ffc08d9857a5afa01438d2d2080cc9f2d394cf84c00f5
diff --git a/app-portage/elt-patches/elt-patches-20170422.ebuild b/app-portage/elt-patches/elt-patches-20170422.ebuild
new file mode 100644
index 000000000000..a9826dc2c085
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20170422.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~amd64-linux ~arm-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt ~x64-cygwin ~x86-cygwin"
+IUSE=""
+
+RDEPEND="sys-apps/gentoo-functions"
+DEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}