summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/euscan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/euscan')
-rw-r--r--app-portage/euscan/Manifest1
-rw-r--r--app-portage/euscan/euscan-0.1.1-r1.ebuild33
-rw-r--r--app-portage/euscan/euscan-9999.ebuild34
-rw-r--r--app-portage/euscan/metadata.xml8
4 files changed, 76 insertions, 0 deletions
diff --git a/app-portage/euscan/Manifest b/app-portage/euscan/Manifest
new file mode 100644
index 000000000000..7db0dd0aa2a9
--- /dev/null
+++ b/app-portage/euscan/Manifest
@@ -0,0 +1 @@
+DIST euscan-0.1.1.tar.gz 441780 SHA256 cbf89803c0c8d6025239f0abd1ac17179c8ff81b1b059be7fc9415a8cfe6dd7e SHA512 2f55f8f4b0fd46b13c981ba94be29a62f16fe2890ce03f99ac14b1488c2ebb59abdaee12f671d679b934b4fd875ee27e751d2c305420f7cfb08e69ec899a75ab WHIRLPOOL 602bc0e3ee60ee6acc6c39bd477957a544fecfd81b38bbd06e46adab246f16889700b38bf6dde306b9978357e521ebf4d185364fd37f765696cde53836a8e127
diff --git a/app-portage/euscan/euscan-0.1.1-r1.ebuild b/app-portage/euscan/euscan-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..00cde1d27d81
--- /dev/null
+++ b/app-portage/euscan/euscan-0.1.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Ebuild upstream scan utility"
+HOMEPAGE="http://euscan.iksaif.net"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
diff --git a/app-portage/euscan/euscan-9999.ebuild b/app-portage/euscan/euscan-9999.ebuild
new file mode 100644
index 000000000000..2dae71a13d16
--- /dev/null
+++ b/app-portage/euscan/euscan-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Ebuild upstream scan utility"
+HOMEPAGE="http://euscan.iksaif.net"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/iksaif/euscan.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
diff --git a/app-portage/euscan/metadata.xml b/app-portage/euscan/metadata.xml
new file mode 100644
index 000000000000..bcc2cc5f2da5
--- /dev/null
+++ b/app-portage/euscan/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>iksaif@gentoo.org</email>
+ <name>Corentin Chary</name>
+ </maintainer>
+</pkgmetadata>