summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-06 22:51:28 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-05-06 22:51:44 +0200
commit5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b (patch)
tree79bdb7c867bd65ba83ee1da1798cde124f0ae184 /app-portage/g-cpan/g-cpan-9999.ebuild
parentvirtual/perl-Memoize: Copy keywords from provider =dev-lang/perl-5.20.2 (diff)
downloadgentoo-5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b.tar.gz
gentoo-5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b.tar.bz2
gentoo-5fde9b5cebf8bcbe36f6901b740dd80db2ddb30b.zip
app-portage/g-cpan: Various updates to live ebuild and version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-portage/g-cpan/g-cpan-9999.ebuild')
-rw-r--r--app-portage/g-cpan/g-cpan-9999.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/app-portage/g-cpan/g-cpan-9999.ebuild b/app-portage/g-cpan/g-cpan-9999.ebuild
index 1ff7291fd259..a547d863bb0e 100644
--- a/app-portage/g-cpan/g-cpan-9999.ebuild
+++ b/app-portage/g-cpan/g-cpan-9999.ebuild
@@ -10,25 +10,34 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
SRC_URI=""
else
- SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
+ SRC_URI="https://github.com/gentoo-perl/g-cpan/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
-DESCRIPTION="g-cpan: generate and install CPAN modules using portage"
+DESCRIPTION="Autogenerate and install ebuilds for CPAN modules"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
-IUSE=""
+IUSE="test"
-DEPEND="
- >=dev-perl/YAML-0.60
- >=dev-perl/Shell-EnvImporter-1.70.0-r2
+COMMONDEPEND="
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
dev-perl/Log-Agent
+ virtual/perl-Memoize
+ virtual/perl-IO
+ dev-perl/Shell-EnvImporter
+ virtual/perl-Term-ANSIColor
+ >=dev-perl/YAML-0.60
"
-RDEPEND="${DEPEND}
+RDEPEND="${COMMONDEPEND}
>=sys-apps/portage-2.0.0
"
+DEPEND="${COMMONDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
src_install() {
perl-module_src_install
@@ -39,8 +48,8 @@ src_install() {
}
pkg_postinst() {
- elog "If you want to use g-cpan besides root you may wish to"
- elog " adjust the permissions on /var/tmp/g-cpan or add users into portage group."
+ elog "If you want to use g-cpan as non root user you may wish to adjust"
+ elog "the permissions on /var/tmp/g-cpan or add users to the portage group."
elog "Please note that some CPAN packages need additional manual"
elog "parameters or tweaking, due to bugs in their build systems."
}