summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-11 19:34:02 +0200
committerAaron Bauman <bman@gentoo.org>2019-02-09 15:12:32 -0500
commit3ff945c37f253d63428ecfcd5f4c78f742cb8e63 (patch)
treee9a2659e0d628b12202794af68ad57fe1058b07f /app-portage/g-sorcery
parentdev-libs/faxpp: EAPI7 revbump, improve ebuild (diff)
downloadgentoo-3ff945c37f253d63428ecfcd5f4c78f742cb8e63.tar.gz
gentoo-3ff945c37f253d63428ecfcd5f4c78f742cb8e63.tar.bz2
gentoo-3ff945c37f253d63428ecfcd5f4c78f742cb8e63.zip
app-portage/g-sorcery: EAPI7, minor improvements
Closes: https://bugs.gentoo.org/665718 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/9829 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-portage/g-sorcery')
-rw-r--r--app-portage/g-sorcery/g-sorcery-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-portage/g-sorcery/g-sorcery-9999.ebuild b/app-portage/g-sorcery/g-sorcery-9999.ebuild
index 8425f5282fcc..bb8f8a3556e9 100644
--- a/app-portage/g-sorcery/g-sorcery-9999.ebuild
+++ b/app-portage/g-sorcery/g-sorcery-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
@@ -27,14 +27,16 @@ RDEPEND="${DEPEND}"
PDEPEND=">=app-portage/layman-2.2.0[g-sorcery(-),${PYTHON_USEDEP}]"
python_test() {
- PYTHONPATH="." "${PYTHON}" scripts/run_tests.py
+ PYTHONPATH="." "${PYTHON}" scripts/run_tests.py || die
}
python_install_all() {
distutils-r1_python_install_all
doman docs/*.8
- dohtml docs/developer_instructions.html
+ docinto html
+ dodoc docs/developer_instructions.html
diropts -m0777
- dodir /var/lib/g-sorcery
+ dodir /var/lib/${PN}
+ keepdir /var/lib/${PN}
}