summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-30 23:11:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-30 23:28:19 +0200
commitb85287dd1258d76ec40e9c0224eb91c60ddbb40d (patch)
treefe8f8a672165cf4fdeb605d659cf26e13a06b7c6 /app-portage/gemato/gemato-15.2.ebuild
parentdev-python/ruamel-yaml-clib: add self as comaintainer (diff)
downloadgentoo-b85287dd1258d76ec40e9c0224eb91c60ddbb40d.tar.gz
gentoo-b85287dd1258d76ec40e9c0224eb91c60ddbb40d.tar.bz2
gentoo-b85287dd1258d76ec40e9c0224eb91c60ddbb40d.zip
app-portage/gemato: Bump to 15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gemato/gemato-15.2.ebuild')
-rw-r--r--app-portage/gemato/gemato-15.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-portage/gemato/gemato-15.2.ebuild b/app-portage/gemato/gemato-15.2.ebuild
new file mode 100644
index 000000000000..268ee6d821e3
--- /dev/null
+++ b/app-portage/gemato/gemato-15.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}