summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-16 14:14:57 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-16 14:31:53 +0100
commit0fbd2e498a58d3f513c1c02cfad18782d6f230d1 (patch)
tree31f88ed9c079cce684ee3e4b20547a9c5dc7096c /app-portage/gemato
parentdev-python/bert: initial commit (diff)
downloadgentoo-0fbd2e498a58d3f513c1c02cfad18782d6f230d1.tar.gz
gentoo-0fbd2e498a58d3f513c1c02cfad18782d6f230d1.tar.bz2
gentoo-0fbd2e498a58d3f513c1c02cfad18782d6f230d1.zip
app-portage/gemato: Bump to 12.1
Bump to new 12.1 version. Includes mostly a fix to respect http_proxy. Closes: https://bugs.gentoo.org/649642
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-12.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index a89a501087a1..d57a033c45d5 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,2 +1,3 @@
DIST gemato-11.2.tar.gz 66260 BLAKE2B 94b7f4a6718314e767676589b10addb05d52133e7e860b257cb558f31ffea27c88bc06bfd2fed7268bfd34179aaee77a9a6e7ffd3bd3fc4e43987e719d809f1e SHA512 61c5a8dccbb99c5ff7880a4e3d26a3f468a70e9622b7aebf53d312cc7105ec7c9abb04d00acdfa9cac29c4779b267abc35074272b7c921f8221d18383b0d445c
DIST gemato-12.0.tar.gz 66625 BLAKE2B 736593356edb10c3e46f70dc12c91712d263f6814e6b786fd63219f05d55eda8f305309d24b7043d969aad5e394b590c3e054f2e91a4d9cc539fdc809e13e1ff SHA512 a7a31e55574e15754ed8cce65a9bbd41fe16f71a641ebc2e5054c8dfacc10c21f22b580edbe3cc001253b4ab7276d02b6dfe81b30e68e009bd24d22b2dd100ed
+DIST gemato-12.1.tar.gz 66807 BLAKE2B 7a6155f337d382bdea7fb4f0bbcb0982e8d4237502dfa7fd8006754bc15e2bfe1f58f133f8cc24ee39eaf947e0770f9ff0672769daa0f03d790ef88958877417 SHA512 7d6287b335121d38859e43ce0818ebb86c51105ed836594f0540fda5ff683a6e58ce09b7dad9cea0667e6379cca6902225b095a3d0922a12cd8c62a36b11386c
diff --git a/app-portage/gemato/gemato-12.1.ebuild b/app-portage/gemato/gemato-12.1.ebuild
new file mode 100644
index 000000000000..41600021c7a3
--- /dev/null
+++ b/app-portage/gemato/gemato-12.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-cygwin ~amd64-fbsd"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}