summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-27 00:14:55 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-27 00:18:29 +0100
commit2b39ae9cd1bc06c2f0f523d030941d8d66438355 (patch)
tree423d830bd919047da412d89885dd6c8bfe57bf1b /app-portage/gemato
parentapp-portage/gemato: Update -9999 to use setuptools (diff)
downloadgentoo-2b39ae9cd1bc06c2f0f523d030941d8d66438355.tar.gz
gentoo-2b39ae9cd1bc06c2f0f523d030941d8d66438355.tar.bz2
gentoo-2b39ae9cd1bc06c2f0f523d030941d8d66438355.zip
app-portage/gemato: Bump to v8
Closes: https://bugs.gentoo.org/638924
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-8.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 648d2c9352f5..2ec3502bb1c3 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,2 +1,3 @@
DIST gemato-4.tar.gz 57334 BLAKE2B 5aad3950e8b7fcf42d088de3b9dd5ded5eaeeb3f91414c38b79eaa4afd4799ccb4084da8a8bdf1bec67b82de8dd09a4c2977f07932a4c63bc833916d184418eb SHA512 a6747a83020efe72ad356873b1648bcf80828efaf9248e17e46cf626f879ebb77571c28d4097ebe56f891a0c096a81feed84bacbd04b37e6a6ce5f0ec37d27ba
DIST gemato-7.tar.gz 57456 BLAKE2B e88d2db66b207ab226f9d8cc000dea6b337a38ebb7ff0bfd41416c0f15fa0c5b36951ff2274bd466798718577bafb8ade5b791db986d4e2e1a34c5318acae79e SHA512 4a278d14c52daefc2a9d16096256df933456f11eabb8997c0293ac59754b7b57f4a9e6edd1d127c9303a4762e14ffcbcaac378f709edd5ded91e0216b7bcca33
+DIST gemato-8.tar.gz 57379 BLAKE2B e83cba508ed781667abab3e18059f838c99e92217a7f1dde90b2cc4200a0ab83baabf789bc6bc978b4f080bf285ab9b7ea62e86a98c272abf3889093d780eac3 SHA512 9e5e7c304166d311b7101330b36c3d781e5d3901feb5247235ed04a8aa316416f6045658fab176e34ca6c2d6653eda66ef19789b39a60cb316add9985c9a8040
diff --git a/app-portage/gemato/gemato-8.ebuild b/app-portage/gemato/gemato-8.ebuild
new file mode 100644
index 000000000000..ae1641c98ca9
--- /dev/null
+++ b/app-portage/gemato/gemato-8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# backports.lzma is broken with pypy
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+blake2 bzip2 +gpg lzma sha3"
+
+RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}