summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-25 11:04:09 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-25 19:57:22 +0100
commit5fdd6ddec2358b82745277a6c42cb770fad7572d (patch)
treed10c049f9957cb50f4133587b10871df16c52bac /app-portage/gemato
parentsys-apps/portage: Add USE=rsync-verify to control gemato verification (diff)
downloadgentoo-5fdd6ddec2358b82745277a6c42cb770fad7572d.tar.gz
gentoo-5fdd6ddec2358b82745277a6c42cb770fad7572d.tar.bz2
gentoo-5fdd6ddec2358b82745277a6c42cb770fad7572d.zip
app-portage/gemato: Remove obsolete portage-postsync
Remove the Portage repo.postsync.d file that is now obsolete given built-in gemato support in Portage. Closes: https://github.com/gentoo/gentoo/pull/6956
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/gemato-10.3.ebuild14
-rw-r--r--app-portage/gemato/gemato-9999.ebuild14
2 files changed, 4 insertions, 24 deletions
diff --git a/app-portage/gemato/gemato-10.3.ebuild b/app-portage/gemato/gemato-10.3.ebuild
index fc3300922c24..80473b478f61 100644
--- a/app-portage/gemato/gemato-10.3.ebuild
+++ b/app-portage/gemato/gemato-10.3.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+blake2 bzip2 +gpg lzma +portage-postsync sha3 test"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test"
MODULE_RDEPEND="
blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
@@ -24,20 +24,10 @@ MODULE_RDEPEND="
sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- portage-postsync? ( app-crypt/gentoo-keys )"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${MODULE_RDEPEND} )"
python_test() {
esetup.py test
}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use portage-postsync; then
- exeinto /etc/portage/repo.postsync.d
- doexe utils/repo.postsync.d/00gemato
- fi
-}
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index ddcbd59df71b..573302e781eb 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -16,7 +16,7 @@ EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS=""
-IUSE="+blake2 bzip2 +gpg lzma +portage-postsync sha3 test"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test"
MODULE_RDEPEND="
blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
@@ -26,20 +26,10 @@ MODULE_RDEPEND="
sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- portage-postsync? ( app-crypt/gentoo-keys )"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${MODULE_RDEPEND} )"
python_test() {
esetup.py test
}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use portage-postsync; then
- exeinto /etc/portage/repo.postsync.d
- doexe utils/repo.postsync.d/00gemato
- fi
-}