summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-16 02:38:02 -0500
committerMike Frysinger <vapier@gentoo.org>2017-02-16 02:38:42 -0500
commit67428d0af631499980154b34f4e5267d95956c74 (patch)
tree93ff62283d8d3962cff1203c03a5e0a8884f6616 /app-portage/gentoolkit-dev
parentapp-portage/gentoolkit-dev: mark 0.3.0 arm/arm64/m68k/s390/sh stable #605976 (diff)
downloadgentoo-67428d0af631499980154b34f4e5267d95956c74.tar.gz
gentoo-67428d0af631499980154b34f4e5267d95956c74.tar.bz2
gentoo-67428d0af631499980154b34f4e5267d95956c74.zip
app-portage/gentoolkit-dev: version bump to 0.3.1
Diffstat (limited to 'app-portage/gentoolkit-dev')
-rw-r--r--app-portage/gentoolkit-dev/Manifest1
-rw-r--r--app-portage/gentoolkit-dev/gentoolkit-dev-0.3.1.ebuild81
-rw-r--r--app-portage/gentoolkit-dev/gentoolkit-dev-9999.ebuild3
3 files changed, 84 insertions, 1 deletions
diff --git a/app-portage/gentoolkit-dev/Manifest b/app-portage/gentoolkit-dev/Manifest
index 5b140fbb652f..4d8725d2b0a2 100644
--- a/app-portage/gentoolkit-dev/Manifest
+++ b/app-portage/gentoolkit-dev/Manifest
@@ -1,2 +1,3 @@
DIST gentoolkit-dev-0.2.8.3.tar.gz 53322 SHA256 b9f96deb53adacf7885c937e1c92688a40839a3992da551616f8745835ec59fb SHA512 f55362e46928633598cb07640505202521e3f4bdaade1faecb4ac14ba1bee0489207cb7ab03531e06d7922446a57083365f51c63ceb8cf1e0badba9ac503c16e WHIRLPOOL 9bb50b92c52c62a74249885ff7d82d6ba2426de6b7052b2e65673a85c6dfe76c201d899e71b8d327a3fed550a1cf1a75616cda369d7f5f37bc93912a8d7845e5
DIST gentoolkit-dev-0.3.0.tar.gz 58655 SHA256 c42d525560f5c85f48e9b2aeb02a5f3ee04e80e52c90e5d1a00eed1ebe9df671 SHA512 d15f6546cf88af0832c14eb003c72b5906bb9b9f078c903e1e444b12c2e432fd1a2fa077eda5496e222cb50cfd5a705e86044b9a1c0164ac6b4b38268461ced5 WHIRLPOOL b3db58c6941ad5ae04fc581de8785d9e0fe6c3b49bdabf401732e881b2e2a1489eb86c3fd650cafe6b56bf26c74ad25dffe8dfb7fdc8b374b3bb0427dd34c2e4
+DIST gentoolkit-dev-0.3.1.tar.gz 58472 SHA256 f68e8647b799c6872598a5adfe6a028af6b8521ae5cd5a6615b796c906e5304c SHA512 e47fa698710132914c2de6d25f7450b90383b9d6283e927221bec30be3a56de93c09e81c35e025dee2f01bd5c2f10cf231fc392c415849029529712cd81aea19 WHIRLPOOL a3fc98b9bf7e4086245795abbd1d71fe1da394aba90f0cc3ae3258f6b7be79363c171dab45d40b9bf37f008f8b0da4bf674f52b8d11c48d1cf06237c8746acca
diff --git a/app-portage/gentoolkit-dev/gentoolkit-dev-0.3.1.ebuild b/app-portage/gentoolkit-dev/gentoolkit-dev-0.3.1.ebuild
new file mode 100644
index 000000000000..aef16474a148
--- /dev/null
+++ b/app-portage/gentoolkit-dev/gentoolkit-dev-0.3.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/gentoolkit.git
+ https://anongit.gentoo.org/git/proj/gentoolkit.git"
+ EGIT_BRANCH="gentoolkit-dev"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of developer scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+ dev-lang/perl
+ sys-apps/diffutils"
+DEPEND="${PYTHON_DEPS}
+ test? ( ${CDEPEND} )"
+RDEPEND="${PYTHON_DEPS}
+ ${CDEPEND}"
+
+src_prepare() {
+ if [[ -n ${EPREFIX} ]] ; then
+ # fix shebangs of scripts
+ local d p
+ ebegin "Fixing shebangs"
+ for d in src/* ; do
+ p=${d#*/}
+ sed -i \
+ -e "1s:\(\(/usr\)\?/bin/\):${EPREFIX}\1:" \
+ ${d}/${p}* \
+ || die "failed to fix ${d}/${p}"
+ done
+ eend $?
+
+ # fix repo location
+ sed -i \
+ -e "s:portage\.db\['/'\]:portage.db['${EPREFIX}/']:g" \
+ src/ekeyword/ekeyword.py \
+ || die "failed to set EPREFIX in ekeyword"
+ # fix repo name
+ sed -i \
+ -e "s:repo='gentoo':repo='gentoo_prefix':g" \
+ src/ekeyword/ekeyword.py \
+ || die "failed to set correct reponame in ekeyword"
+ fi
+}
+
+src_test() {
+ # echangelog test is not able to run as root
+ # the EUID check may not work for everybody
+ if [[ ${EUID} -ne 0 ]]; then
+ python_foreach_impl emake test
+ else
+ ewarn "test skipped, please re-run as non-root if you wish to test ${PN}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ python_replicate_script "${ED}"/usr/bin/{ekeyword,imlate}
+}
diff --git a/app-portage/gentoolkit-dev/gentoolkit-dev-9999.ebuild b/app-portage/gentoolkit-dev/gentoolkit-dev-9999.ebuild
index 183bfc83ad6b..1a2151f82819 100644
--- a/app-portage/gentoolkit-dev/gentoolkit-dev-9999.ebuild
+++ b/app-portage/gentoolkit-dev/gentoolkit-dev-9999.ebuild
@@ -15,7 +15,8 @@ if [[ ${PV} == 9999 ]]; then
https://anongit.gentoo.org/git/proj/gentoolkit.git"
EGIT_BRANCH="gentoolkit-dev"
else
- SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi