summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-17 01:33:49 +0100
committerSam James <sam@gentoo.org>2021-08-17 01:44:39 +0100
commit274cbff94b0b529b63aae59d08976c3b783a8550 (patch)
tree4cd589a4739a41d14d02178682d845931795e28f /app-portage/gentoolkit
parentlicenses: sync SIP license with latest upstream version (diff)
downloadgentoo-274cbff94b0b529b63aae59d08976c3b783a8550.tar.gz
gentoo-274cbff94b0b529b63aae59d08976c3b783a8550.tar.bz2
gentoo-274cbff94b0b529b63aae59d08976c3b783a8550.zip
app-portage/gentoolkit: [QA] add missing tmpfiles_process call
Revbump for the missing tmpfiles.eclass inherit which adds a virtual/tmpfiles RDEPEND. Closes: https://bugs.gentoo.org/808655 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/gentoolkit')
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.5.0-r3.ebuild (renamed from app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild)6
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.5.1-r1.ebuild (renamed from app-portage/gentoolkit/gentoolkit-0.5.1.ebuild)6
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild6
3 files changed, 6 insertions, 12 deletions
diff --git a/app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild b/app-portage/gentoolkit/gentoolkit-0.5.0-r3.ebuild
index b5d01fea1c2e..436222faf8fa 100644
--- a/app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.5.0-r3.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
PYTHON_REQ_USE="xml(+),threads(+)"
-inherit distutils-r1
+inherit distutils-r1 tmpfiles
DESCRIPTION="Collection of administration scripts for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
@@ -53,9 +53,7 @@ pkg_preinst() {
}
pkg_postinst() {
- # Create cache directory for revdep-rebuild
- mkdir -p -m 0755 "${EROOT}"/var/cache
- mkdir -p -m 0700 "${EROOT}"/var/cache/revdep-rebuild
+ tmpfiles_process revdep-rebuild.conf
if [[ ${SHOW_GENTOOKIT_DEV_DEPRECATED_MSG} ]]; then
elog "Starting with version 0.4.0, ebump, ekeyword and imlate are now"
diff --git a/app-portage/gentoolkit/gentoolkit-0.5.1.ebuild b/app-portage/gentoolkit/gentoolkit-0.5.1-r1.ebuild
index 5e66d2ff7856..bb95e6309cc8 100644
--- a/app-portage/gentoolkit/gentoolkit-0.5.1.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.5.1-r1.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="xml(+),threads(+)"
-inherit distutils-r1
+inherit distutils-r1 tmpfiles
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoolkit.git"
@@ -46,9 +46,7 @@ python_prepare_all() {
}
pkg_postinst() {
- # Create cache directory for revdep-rebuild
- mkdir -p -m 0755 "${EROOT}"/var/cache
- mkdir -p -m 0700 "${EROOT}"/var/cache/revdep-rebuild
+ tmpfiles_process revdep-rebuild.conf
# Only show the elog information on a new install
if [[ ! ${REPLACING_VERSIONS} ]]; then
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index 73c07b7f3706..db0fa476bfac 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="xml(+),threads(+)"
-inherit distutils-r1
+inherit distutils-r1 tmpfiles
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoolkit.git"
@@ -46,9 +46,7 @@ python_prepare_all() {
}
pkg_postinst() {
- # Create cache directory for revdep-rebuild
- mkdir -p -m 0755 "${EROOT}"/var/cache
- mkdir -p -m 0700 "${EROOT}"/var/cache/revdep-rebuild
+ tmpfiles_process revdep-rebuild.conf
# Only show the elog information on a new install
if [[ ! ${REPLACING_VERSIONS} ]]; then