summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 14:27:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 14:29:16 +0200
commitdb3e1247e84e84ea35e4834cce6e03a5d55158de (patch)
treee0429e8ff17d52a04fd3c15482fb5694ce45c6e6 /app-portage/gpyutils/gpyutils-0.4.5.ebuild
parentx11-themes/fvwm-crystal: Remove old (diff)
downloadgentoo-db3e1247e84e84ea35e4834cce6e03a5d55158de.tar.gz
gentoo-db3e1247e84e84ea35e4834cce6e03a5d55158de.tar.bz2
gentoo-db3e1247e84e84ea35e4834cce6e03a5d55158de.zip
app-portage/gpyutils: Bump to 0.4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gpyutils/gpyutils-0.4.5.ebuild')
-rw-r--r--app-portage/gpyutils/gpyutils-0.4.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-portage/gpyutils/gpyutils-0.4.5.ebuild b/app-portage/gpyutils/gpyutils-0.4.5.ebuild
new file mode 100644
index 000000000000..fa25bd96a86c
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.4.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://github.com/mgorny/gpyutils/"
+SRC_URI="
+ https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}