summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 14:54:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 14:59:07 +0200
commit061c46cd73c555a15404b0c7c9c90cb51751c2da (patch)
treeb0c25ce557a16eb4bcc0cfd3b559223c1d6f1e8d /app-portage/gpyutils
parentvirtual/opencl: reorder RDEPEND alternatives (diff)
downloadgentoo-061c46cd73c555a15404b0c7c9c90cb51751c2da.tar.gz
gentoo-061c46cd73c555a15404b0c7c9c90cb51751c2da.tar.bz2
gentoo-061c46cd73c555a15404b0c7c9c90cb51751c2da.zip
app-portage/gpyutils: Bump to 0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gpyutils')
-rw-r--r--app-portage/gpyutils/Manifest1
-rw-r--r--app-portage/gpyutils/gpyutils-0.5.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/gpyutils/Manifest b/app-portage/gpyutils/Manifest
index 619ed92d89ae..f80c5fe78038 100644
--- a/app-portage/gpyutils/Manifest
+++ b/app-portage/gpyutils/Manifest
@@ -1 +1,2 @@
DIST gpyutils-0.4.5.tar.gz 20037 BLAKE2B f628c11e0ae2c9bb02a024e1b7dcab7092e7b01c14078683c47a8ca00d71021b988c51d80ab8b322891f9ecd4bb11c7bfe7d300f3bcbe489a977b18244ead085 SHA512 f68c87b5a35aece182bf2f9f93fe89f061dd49b4b75fabb7637038aee1e5301797af1d889a75829048eeb05dda0233461a2f2600e185214600a282cea50d1d3c
+DIST gpyutils-0.5.tar.gz 23472 BLAKE2B 7f13be342a28eb27beb530f5f98d1a096f0436c44abbfcc2a413673c2433261d61ba5ac0bd5afba8bd569d2f45f27fda0faf083ce2f00d1f8c0c0651f027cb33 SHA512 80bfe7754876b071fa8e4dcf5523564d7145715ab292c06a31296a344bc7ca298fee6171e2b39dfe5c0b762c1fb8c69ca9040744d39150c80e22fb35e3876808
diff --git a/app-portage/gpyutils/gpyutils-0.5.ebuild b/app-portage/gpyutils/gpyutils-0.5.ebuild
new file mode 100644
index 000000000000..07c9616731d5
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://github.com/mgorny/gpyutils/"
+SRC_URI="
+ https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}