summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-26 00:01:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-26 00:06:27 +0000
commita87068ce30830fd698b6bdf32412483b110977ac (patch)
tree56e9b298a646f54dbe2d1a0a40ff1e55beb1386d /app-portage/hackport/files
parenttoolchain.eclass: drop PRERELEASE support (diff)
downloadgentoo-a87068ce30830fd698b6bdf32412483b110977ac.tar.gz
gentoo-a87068ce30830fd698b6bdf32412483b110977ac.tar.bz2
gentoo-a87068ce30830fd698b6bdf32412483b110977ac.zip
app-portage/hackport: bump up to 0.6.3
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/704778 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-portage/hackport/files')
-rw-r--r--app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch33
-rw-r--r--app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch79
-rw-r--r--app-portage/hackport/files/hackport-0.6.3-old-filepath.patch40
3 files changed, 152 insertions, 0 deletions
diff --git a/app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch b/app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch
new file mode 100644
index 000000000000..21c848ab53c5
--- /dev/null
+++ b/app-portage/hackport/files/hackport-0.6.3-missing-ffi.patch
@@ -0,0 +1,33 @@
+From 4264f8bc91dabce03ac858388358ff5f4c6db8df Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sat, 25 Jan 2020 23:52:58 +0000
+Subject: [PATCH 2/3] hackport.cabal: add missing ForeignFunctionInterface
+ extension
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+gcc-8.0 does not enable `ForeignFunctionInterface` by default.
+
+Reported-by: Toralf Förster
+Bug: https://bugs.gentoo.org/704778
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ hackport.cabal | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/hackport.cabal b/hackport.cabal
+index 049933e00..70928fe6b 100644
+--- a/hackport.cabal
++++ b/hackport.cabal
+@@ -70,6 +70,7 @@ Executable hackport
+ DoAndIfThenElse,
+ EmptyDataDecls,
+ ExistentialQuantification,
++ ForeignFunctionInterface,
+ FlexibleContexts,
+ FlexibleInstances,
+ GADTs,
+--
+2.25.0
+
diff --git a/app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch b/app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch
new file mode 100644
index 000000000000..fa6c446cf38b
--- /dev/null
+++ b/app-portage/hackport/files/hackport-0.6.3-missing-test-deps.patch
@@ -0,0 +1,79 @@
+From 4cd81196f7a477327ce87971b376e785f362b9b7 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Fri, 24 Jan 2020 08:09:34 +0000
+Subject: [PATCH 1/3] hackport.cabal: add missing test depends
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ hackport.cabal | 21 ++++++++++++++++++++-
+ 1 file changed, 20 insertions(+), 1 deletion(-)
+
+diff --git a/hackport.cabal b/hackport.cabal
+index 94d345292..049933e00 100644
+--- a/hackport.cabal
++++ b/hackport.cabal
+@@ -76,6 +76,7 @@ Executable hackport
+ GeneralizedNewtypeDeriving,
+ KindSignatures,
+ MultiParamTypeClasses,
++ -- cabal
+ PatternGuards,
+ RankNTypes,
+ RecordWildCards,
+@@ -86,7 +87,6 @@ Executable hackport
+ ViewPatterns
+ other-extensions:
+ DeriveDataTypeable,
+- PatternGuards,
+ -- extensions due to bundled cabal-install
+ CPP,
+ ForeignFunctionInterface,
+@@ -151,9 +151,15 @@ Test-Suite test-resolve-category
+ pretty,
+ process,
+ split,
++ text,
+ time,
++ transformers,
+ unix,
+ xml
++ default-extensions:
++ -- cabal
++ PatternGuards,
++ DoAndIfThenElse
+
+ Test-Suite test-print-deps
+ ghc-options: -Wall
+@@ -174,9 +180,15 @@ Test-Suite test-print-deps
+ parsec,
+ pretty,
+ process,
++ text,
+ time,
++ transformers,
+ unix,
+ xml
++ default-extensions:
++ -- cabal
++ PatternGuards,
++ DoAndIfThenElse
+
+ Test-Suite test-normalize-deps
+ ghc-options: -Wall
+@@ -197,6 +209,13 @@ Test-Suite test-normalize-deps
+ parsec,
+ pretty,
+ process,
++ text,
+ time,
++ transformers,
+ unix,
+ xml
++
++ default-extensions:
++ -- cabal
++ PatternGuards,
++ DoAndIfThenElse
+--
+2.25.0
+
diff --git a/app-portage/hackport/files/hackport-0.6.3-old-filepath.patch b/app-portage/hackport/files/hackport-0.6.3-old-filepath.patch
new file mode 100644
index 000000000000..c660db766b26
--- /dev/null
+++ b/app-portage/hackport/files/hackport-0.6.3-old-filepath.patch
@@ -0,0 +1,40 @@
+From b4fe6e48679084ca28c1192612c60599ae81808c Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sat, 25 Jan 2020 23:53:39 +0000
+Subject: [PATCH 3/3] Merge.hs: avoid using isExtensionOf
+
+`isExtensionOf` is not available in gcc-8.0.
+
+Reported-by: Jeremy Stent
+Bug: https://bugs.gentoo.org/704778
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ Merge.hs | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Merge.hs b/Merge.hs
+index 645817345..522a3739d 100644
+--- a/Merge.hs
++++ b/Merge.hs
+@@ -39,7 +39,8 @@ import System.Directory ( getCurrentDirectory
+ , listDirectory
+ )
+ import System.Process (system)
+-import System.FilePath ((</>), isExtensionOf)
++import System.FilePath ((</>))
++import qualified System.FilePath as SF
+ import System.Exit
+
+ import qualified Cabal2Ebuild as C2E
+@@ -183,7 +184,7 @@ getPreviousPackageId pkgDir newPkgId = do
+ . L.sortOn (Portage.pkgVersion)
+ . filter (<newPkgId)
+ $ Portage.filePathToPackageId newPkgId
+- <$> filter (\fp -> ".ebuild" `isExtensionOf` fp) pkgDir
++ <$> filter (\fp -> SF.takeExtension fp == ".ebuild") pkgDir
+ case pkgIds of
+ x:_ -> Just x
+ _ -> Nothing
+--
+2.25.0
+