summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-08-24 13:07:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-08-24 13:54:26 +0100
commit989094927eb9d90cac212c037c893172e310a11a (patch)
tree3dba80c2857c5632c46586d3195e169ff64f7c8f /app-portage/hackport/hackport-0.5.6.ebuild
parentapp-portage/hackport: sync support portage-mgorny into live ebuild (diff)
downloadgentoo-989094927eb9d90cac212c037c893172e310a11a.tar.gz
gentoo-989094927eb9d90cac212c037c893172e310a11a.tar.bz2
gentoo-989094927eb9d90cac212c037c893172e310a11a.zip
app-portage/hackport: bump up to 0.5.6
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-portage/hackport/hackport-0.5.6.ebuild')
-rw-r--r--app-portage/hackport/hackport-0.5.6.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-portage/hackport/hackport-0.5.6.ebuild b/app-portage/hackport/hackport-0.5.6.ebuild
new file mode 100644
index 000000000000..cc57aa98f593
--- /dev/null
+++ b/app-portage/hackport/hackport-0.5.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="http://hackage.haskell.org/package/hackport"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tests are broken: need path to ebuild tree
+
+RDEPEND="
+ || (
+ <sys-apps/portage-2.3.0
+ sys-apps/portage-mgorny
+ app-portage/repoman
+ )
+ dev-haskell/async:=
+ dev-haskell/base16-bytestring:=
+ dev-haskell/base64-bytestring:=
+ dev-haskell/cryptohash:=
+ dev-haskell/ed25519:=
+ dev-haskell/extensible-exceptions:=
+ dev-haskell/hashable:=
+ >=dev-haskell/http-4000.0.3:=
+ dev-haskell/missingh:=
+ dev-haskell/mtl:=
+ >=dev-haskell/network-2.6:=
+ >=dev-haskell/network-uri-2.6:=
+ dev-haskell/old-locale:=
+ dev-haskell/old-time:=
+ dev-haskell/parsec:=
+ dev-haskell/random:=
+ dev-haskell/regex-compat:=
+ dev-haskell/split:=
+ dev-haskell/stm:=
+ >=dev-haskell/tar-0.5:=
+ >=dev-haskell/xml-1.3.7:=
+ dev-haskell/zlib:=
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hunit )
+"
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+}