summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-15 15:41:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-15 15:43:24 -0400
commita06b9ad51fbe54cb4261df74bfb345d21bb3583e (patch)
treecc2966deca82251e14932c1b441d72711f737c92 /app-portage/iwdevtools/iwdevtools-9999.ebuild
parentkde-apps/konsole: Fix KXmlGUI toolbars and MainWindow size (diff)
downloadgentoo-a06b9ad51fbe54cb4261df74bfb345d21bb3583e.tar.gz
gentoo-a06b9ad51fbe54cb4261df74bfb345d21bb3583e.tar.bz2
gentoo-a06b9ad51fbe54cb4261df74bfb345d21bb3583e.zip
app-portage/iwdevtools: add a postinst elog about bashrc
Planning to write better docs for this, but this needs more direct attention either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools/iwdevtools-9999.ebuild')
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index 773d09d876b2..880f2b284b0c 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -22,3 +22,14 @@ RDEPEND="
src_configure() {
meson_src_configure -Ddocdir=${PF}
}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you"
+ elog "can use the example bashrc directly by creating a symlink:"
+ elog
+ elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ fi
+}