summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-16 02:35:30 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-16 02:45:30 -0500
commite773865752b649a6c41a31e18af8ce0157b7a165 (patch)
treeae0d0e04ea59b0c49108a6daeb53d19ad89d1df7 /app-portage/iwdevtools/iwdevtools-9999.ebuild
parentdev-util/cucumber-wire: add 6.2.1 (diff)
downloadgentoo-e773865752b649a6c41a31e18af8ce0157b7a165.tar.gz
gentoo-e773865752b649a6c41a31e18af8ce0157b7a165.tar.bz2
gentoo-e773865752b649a6c41a31e18af8ce0157b7a165.zip
app-portage/iwdevtools: allow using app-misc/getopt for 9999
It's a bit automagic'y but switching between the two hardly makes sense given the keywords. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools/iwdevtools-9999.ebuild')
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index e646ee963668..238ca161ff34 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,7 @@ RDEPEND="
sys-apps/diffutils
sys-apps/file
sys-apps/portage
- sys-apps/util-linux"
+ || ( sys-apps/util-linux app-misc/getopt )"
BDEPEND="
sys-apps/help2man
test? ( ${RDEPEND} )"
@@ -34,6 +34,8 @@ src_configure() {
$(meson_use test)
)
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
meson_src_configure
}