summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-21 12:19:20 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-21 12:21:03 -0500
commit50031b4c53b1d882dce93e03dbb3415f4e3e821a (patch)
tree62e4e8e1b342c62d760c868f5126cc67011ff1c1 /app-portage/iwdevtools
parentgnome-extra/cjs: fix build with meson 0.61 (diff)
downloadgentoo-50031b4c53b1d882dce93e03dbb3415f4e3e821a.tar.gz
gentoo-50031b4c53b1d882dce93e03dbb3415f4e3e821a.tar.bz2
gentoo-50031b4c53b1d882dce93e03dbb3415f4e3e821a.zip
app-portage/iwdevtools: add 0.10.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.10.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 3566682aff36..43a82016596c 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,2 +1,3 @@
+DIST iwdevtools-0.10.0.tar.gz 60808 BLAKE2B 31f5288c54513a95199c3e41e7147778276ffaa2a63bb88e49a91680fa53602c4d1883ccf9b78bf63eba2fefec3fcd50e45ce7a599a0b252eadfaca62f2d9a09 SHA512 e03eda68eced8a23476d6681bd8090f80b642c40e5ed7e3ecb758fe04e51f496be02042bb87f6b42e150d28086e7ce14b278a6fdd05f06725b184b328405d412
DIST iwdevtools-0.8.1.tar.gz 58058 BLAKE2B b9f17f68bb073ecf2d8a94fc8b97d95f7188e7526dd6a32cf33aa3b01fe82bf25c696cc2be9cbdc0aaa3a8279532e506ab287d3e25da5d5fb55789064d47aec6 SHA512 cb365e7010d620f2a255db0244ee1a38fd5714a17093b2e2a71627155764165853f99a4477b281b92061f7fe184297a222a8c79c2c62beb8e0656761feee859b
DIST iwdevtools-0.9.0.tar.gz 58476 BLAKE2B c036e151f76578633522f32665b30a2521131c265b5815934feffe2d3028e1e7fea314b2b41a719683b9ecc43f31f4aa7ffc10fe159dc62870bf43dc1da750bd SHA512 7d433d537d7b7ea3954e224be52dcd3a5fcb6be9b9f532096955b778a98d8a8a04e0c03f53615d01603a298859fe2129b3f3b126a671a1e202f08718bb15f104
diff --git a/app-portage/iwdevtools/iwdevtools-0.10.0.ebuild b/app-portage/iwdevtools/iwdevtools-0.10.0.ebuild
new file mode 100644
index 000000000000..a667742fb6d0
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.10.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+
+ if [[ ${REPLACING_VERSIONS} ]] &&
+ ver_test ${REPLACING_VERSIONS} -le 0.7.0; then
+ elog "qa-* bashrcs now use \`eqawarn\` for portage output. If no longer"
+ elog "seeing messages post-emerge, ensure 'qa' is in PORTAGE_ELOG_CLASSES."
+ fi
+}