summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-07-19 14:37:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-07-19 14:37:39 -0400
commit71de7d4fcc5d26a0a6f0be08b34f763b447aad07 (patch)
treea9c1f5f41b555cc4fe9f93cc44d1e21c6dc59921 /app-portage/iwdevtools
parentnet-libs/tox: Bugfix; Add missing variable S. (diff)
downloadgentoo-71de7d4fcc5d26a0a6f0be08b34f763b447aad07.tar.gz
gentoo-71de7d4fcc5d26a0a6f0be08b34f763b447aad07.tar.bz2
gentoo-71de7d4fcc5d26a0a6f0be08b34f763b447aad07.zip
app-portage/iwdevtools: add 0.11.4
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.11.4.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 51b4aa7ff5f4..5913cb675109 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.11.3.tar.gz 84838 BLAKE2B a4f501c24cc70b13ded5ca88599a3c11b076ae3a3464d065fe3999c8cb9268cfd17fc116197c09ddc6b968d7527409b348c0c1bdb939f6ed1b7a2abdfc868774 SHA512 38a62654042b714689fcf813a533ad463b7bdc0a4b501dc37c498e528792104a3db601f82781d889407217c824a9f48233544fb56a012de19fd34fa92d1de06d
+DIST iwdevtools-0.11.4.tar.gz 85480 BLAKE2B 44b86ee22e23320aa1c25676c08638332cbf66882e2610d3bc19580e682e7623c53013534977299fdad1f697a1ca10447d5753f221e839039011bbdccf017f35 SHA512 907755307b5cd617b2e85aabe76558b9b0c1b42e08e0a7d71760250f1ae455ac24a6a676c0707c2a371a80d86d0b60c16d8fa45702ba0e779f7817866bfb3a26
diff --git a/app-portage/iwdevtools/iwdevtools-0.11.4.ebuild b/app-portage/iwdevtools/iwdevtools-0.11.4.ebuild
new file mode 100644
index 000000000000..fc1e35247451
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.11.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}