summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-29 15:47:28 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-29 15:47:38 -0400
commita3552f1b24b24e0b1c46e95fb7698234de1893ae (patch)
tree65248b2bdce0e9556355b140e4ae3ed5614a3bdd /app-portage/iwdevtools
parentsys-devel/gettext: revbump for java changes (diff)
downloadgentoo-a3552f1b24b24e0b1c46e95fb7698234de1893ae.tar.gz
gentoo-a3552f1b24b24e0b1c46e95fb7698234de1893ae.tar.bz2
gentoo-a3552f1b24b24e0b1c46e95fb7698234de1893ae.zip
app-portage/iwdevtools: add 0.11.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.11.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 5185d3bf4b5b..a8c2a84360a8 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,3 +1,4 @@
DIST iwdevtools-0.10.1.tar.gz 61117 BLAKE2B fd5508a40a854987db7f2ecc0e68e100cd6a8b6cc5b90a9901bbf6c16336ebc497861e05a6c1683ac9082aa9f12a03cb47f7116da793fbd8e105ed78aae2bbb3 SHA512 0f04850f15edc8af368a87bbc665c62d5588f4220c2d15ca5c0dd00d2c8135f7e1294217c8aec313650b7b7aae6433b87bdc32306c2c4c6e6747e55a13adbbe0
DIST iwdevtools-0.11.0.tar.gz 81975 BLAKE2B 241c04488cc3da265c1c5a0cbf90ddb938b4e0da10942094f25dcb1d32a0da314a80fba1fc99b1ec54a449905be8eddab896d67194d8e511c1a7378856fd7df2 SHA512 cccbe9461f27233e228529a5fe9c729620647b1e134c723f407bdd23b4fa85f04c6294fc6579a22667dec65b20ad1c26ac9d71b214407c49463aeed6fbaed7d1
DIST iwdevtools-0.11.1.tar.gz 83067 BLAKE2B 8fbdbe21242ccb3e578a8060ced5d4562acc70ffa8789991af00ddeaf8cb232177d2482f06f8092d6b60cc128c1b55a3f5df2eaba985f1d63795e6730c2fa1be SHA512 d893efbc75a3fa7056c2dbe5fa75bbbf262f40f8ddd44347e98559ff4e51572b64698c93b8fb3e92e73d84151cf0a11457d58f898295aae05455ac86fd4bd07d
+DIST iwdevtools-0.11.2.tar.gz 84518 BLAKE2B 1d3920b8a1503a916f913d0c075a1f3c703ca238c55761c0cd6423f68e0395e2eb0c8ab07bf069c3cdf44ab9d07b4652184d790d9b74e1f00cb74e8b86290de6 SHA512 7e4584f8f2141b54bf32828801415e039ceec319095268fccb40f4960d66af2504da97fd6f18b1763f6beaef477ac3b6b0bf7ae9bac08a474de73b420ebd5a43
diff --git a/app-portage/iwdevtools/iwdevtools-0.11.2.ebuild b/app-portage/iwdevtools/iwdevtools-0.11.2.ebuild
new file mode 100644
index 000000000000..c5565f4af071
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.11.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}