summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-01-08 10:39:10 -0500
committerCraig Andrews <candrews@gentoo.org>2019-01-15 11:36:26 -0500
commit4c44df03b20e9277768a96989c90c91a7908fa9b (patch)
tree7d4a81f1fe547af021c02a7ca8e59786d3385810 /app-portage/layman/layman-9999.ebuild
parentmedia-plugins/kodi-pvr-vuplus: 3.16.2 version bump (diff)
downloadgentoo-4c44df03b20e9277768a96989c90c91a7908fa9b.tar.gz
gentoo-4c44df03b20e9277768a96989c90c91a7908fa9b.tar.bz2
gentoo-4c44df03b20e9277768a96989c90c91a7908fa9b.zip
app-portage/layman: Python 3.7, EAPI=7
Closes: https://bugs.gentoo.org/674884 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-portage/layman/layman-9999.ebuild')
-rw-r--r--app-portage/layman/layman-9999.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/app-portage/layman/layman-9999.ebuild b/app-portage/layman/layman-9999.ebuild
index 41753c3c8898..917d938ba62b 100644
--- a/app-portage/layman/layman-9999.ebuild
+++ b/app-portage/layman/layman-9999.ebuild
@@ -1,24 +1,29 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
PYTHON_REQ_USE="xml(+),sqlite?"
-inherit eutils distutils-r1 git-r3 linux-info prefix
+inherit eutils distutils-r1 linux-info prefix
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/layman.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
DESCRIPTION="Tool to manage Gentoo overlays"
-HOMEPAGE="http://layman.sourceforge.net"
-EGIT_REPO_URI="git://anongit.gentoo.org/proj/layman.git"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Layman"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="bazaar cvs darcs +git gpg g-sorcery mercurial sqlite squashfs subversion sync-plugin-portage test"
DEPEND="test? ( dev-vcs/subversion )
- app-text/asciidoc
"
RDEPEND="
@@ -78,11 +83,6 @@ python_test() {
unset suite
}
-python_compile_all() {
- # override MAKEOPTS to prevent build failure
- emake -j1 -C doc
-}
-
python_install_all() {
distutils-r1_python_install_all