summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-27 23:30:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-27 23:34:34 +0100
commit0affe88385e24e740fa723c32f1dfc8b89311e6d (patch)
tree83e2f0e8c1d57780fe50e4485cd3b78969fc6817 /app-portage/nattka
parentapp-portage/nattka: Remove the live ebuild (diff)
downloadgentoo-0affe88385e24e740fa723c32f1dfc8b89311e6d.tar.gz
gentoo-0affe88385e24e740fa723c32f1dfc8b89311e6d.tar.bz2
gentoo-0affe88385e24e740fa723c32f1dfc8b89311e6d.zip
app-portage/nattka: Bump to 0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/nattka')
-rw-r--r--app-portage/nattka/Manifest1
-rw-r--r--app-portage/nattka/nattka-0.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/nattka/Manifest b/app-portage/nattka/Manifest
index 608f2fde4947..d574afcda6fb 100644
--- a/app-portage/nattka/Manifest
+++ b/app-portage/nattka/Manifest
@@ -1 +1,2 @@
DIST nattka-0.2.19.tar.gz 93800 BLAKE2B 65efff2454cdb24f3b71dc5713adbf3bda3976ed958622f7adec14e3708a53531aac6801e838fd21346ce02974fa79bcb82c3f4d2a6555095fa8d81db9ad2992 SHA512 7508a78fa774a9229caa573426839ec84210e9a2d38b7ca9cd47d857b9922b946e9e31fadf946f001565ce6dc65103bca8af58935d7eb2fcf32da423345ce61a
+DIST nattka-0.3.tar.gz 93914 BLAKE2B c38ec336ed202e508e1cb4bfcae0586b94a6fd55df97d5be514caddf0113b9588496492ebc68dbda45c4a3034451368d32a3f53f5ebc8f3136515614ac70ecab SHA512 390b276ab11e5de056e165f95574b5a97edbcad3adf876e20bb6ef8accf94629428c4fc60bbea4eaf883d5e0a9f6e7ea00aff74989d31bdd59c418041d9164dc
diff --git a/app-portage/nattka/nattka-0.3.ebuild b/app-portage/nattka/nattka-0.3.ebuild
new file mode 100644
index 000000000000..92798cde8626
--- /dev/null
+++ b/app-portage/nattka/nattka-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="depgraph-order"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ dev-vcs/git
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ depgraph-order? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest