summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-16 14:05:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-16 14:07:07 +0200
commiteda9718a6864616b941810e46ea619ef416608d2 (patch)
treefb56a516baa4c6abcd47565596e763fe315df92c /app-portage/nattka
parentmedia-sound/puddletag: mask 'quodlibet' USE flag (diff)
downloadgentoo-eda9718a6864616b941810e46ea619ef416608d2.tar.gz
gentoo-eda9718a6864616b941810e46ea619ef416608d2.tar.bz2
gentoo-eda9718a6864616b941810e46ea619ef416608d2.zip
app-portage/nattka: Bump to 0.2.11.1 (backport)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/nattka')
-rw-r--r--app-portage/nattka/Manifest1
-rw-r--r--app-portage/nattka/nattka-0.2.11.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/nattka/Manifest b/app-portage/nattka/Manifest
index b996714d6f77..9aa7dada5f1f 100644
--- a/app-portage/nattka/Manifest
+++ b/app-portage/nattka/Manifest
@@ -1,2 +1,3 @@
+DIST nattka-0.2.11.1.tar.gz 94986 BLAKE2B fa80b514913e1752c2bb581b7d7f2dc1f9e2b7ffdf7672a61fdd2cf49ff5677cd1842949885beb9f9fd7228aa89e1e7b9091fcf77a4a7d3c71b372ba40c9edb3 SHA512 22fb3f3685fb454f768c754a2574efc4b40d1c3abaa4b8283e38a426d1f443f5328ca5c6eb2c06a7240166de36ee9e3af88623dc7ef3f14b99903177bde1cdc5
DIST nattka-0.2.11.tar.gz 93992 BLAKE2B ad088de5f96ec5f7f8b0922420d22ef507e1e79ef3bc3161e6a88cd4714f1007a000ab06a7e21245b2792fd3056474459bf424da0560b8666c5cf46f04a2d763 SHA512 5d9de9f437a15e149ce58348f40f86101c10fe1f4c4ce869e7038ba25fc212c22e024a9999a6197179a0a1e1e82380356d304841c33333e04949caaadef96db7
DIST nattka-0.2.12.tar.gz 92954 BLAKE2B c4ffd44030da0224963d7fa367336d7ab9076b17f03292f5e65b7855823b34374b8d7626c4b97c155d10797f2d550f3c20cac39f68cfbfc4b8038406f37b21b0 SHA512 f1e775895d66505b09a3098525f998f87bb1561538f0e75b993b264f87f61937d7d5c71999018fe93c683366ef81dff5b7fef1e1d44af63153003f70d7933273
diff --git a/app-portage/nattka/nattka-0.2.11.1.ebuild b/app-portage/nattka/nattka-0.2.11.1.ebuild
new file mode 100644
index 000000000000..1e24d6847989
--- /dev/null
+++ b/app-portage/nattka/nattka-0.2.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="depgraph-order"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-util/pkgcheck-0.9[${PYTHON_USEDEP}]
+ dev-vcs/git
+ <sys-apps/pkgcore-0.11.3[${PYTHON_USEDEP}]
+ depgraph-order? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest